您的位置:首页 > 其它

hdu 2899 Strange fuction

2013-07-31 21:04 288 查看

Strange fuction

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2077 Accepted Submission(s): 1556


[align=left]Problem Description[/align]
Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

[align=left]Output[/align]
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

[align=left]Sample Input[/align]

2
100
200

[align=left]Sample Output[/align]

-74.4291
-178.8534

二分练手题

#include<stdio.h>
#include<math.h>
double y;
double solve(double x)
{
double n;
n=42*pow(x,6)+ 48*pow(x,5) + 21*x*x + 10*x ;
return n;
}
int main()
{
int t;
double y,l,r,p,mid,x;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
//  if(solve(100)<y)//貌似没有这种情况
//{
//   x=100;
//  printf("%.4lf\n",6 * pow(x,7)+8*pow(x,6)+7*x*x*x+5*x*x-y*x);
//  continue;
// }
l=0.0,r=100.0;
while(r-l>1e-9)
{
mid=(r+l)/2;
p=solve(mid);
if(p<y)
l=mid;
else
r=mid;

}
x=mid;
p= 6 * pow(x,7)+8*pow(x,6)+7*x*x*x+5*x*x-y*x ;
printf("%.4lf\n",p);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: