您的位置:首页 > 其它

uva 839 Not so Mobile(抽象意义上的建树)

2013-07-31 18:52 465 查看


Not so Mobile 
Before being an ubiquous communications gadget, a mobile was just a structure made of strings and wires suspending colourfull things. This kind of mobile is usually found hanging over cradles of small babies.



The figure illustrates a simple mobile. It is just a wire, suspended by a string, with an object on each side. It can also be seen as a kind of lever with the fulcrum on the point where the string ties the wire. From the lever principle we know that to balance
a simple mobile the product of the weight of the objects by their distance to the fulcrum must be equal. That is Wl×Dl = Wr×Dr where Dl is
the left distance, Dr is the right distance, Wl is the left weight and Wr is the right weight.

In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure. In this case it is not so straightforward to check if the mobile is balanced so we need you to write a program that, given a description of a mobile as input,
checks whether the mobile is in equilibrium or not.




Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank
line, and there is also a blank line between two consecutive inputs.

The input is composed of several lines, each containing 4 integers separated by a single space. The 4 integers represent the distances of each object to the fulcrum and their weights, in the format: Wl Dl Wr Dr

If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define the the sub-mobile. In this case we compute the weight of the sub-mobile
as the sum of weights of all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are zero then the following lines define two sub-mobiles:
first the left then the right one.


Output 

For each test case, the output must follow the description
below. The outputs of two consecutive cases will be separated by a blank line.

Write `YES' if the mobile is in equilibrium, write `NO' otherwise.


Sample Input 

1

0 2 0 4
0 3 0 1
1 1 1 1
2 4 4 2
1 6 3 2



Sample Output 

YES

题目大意:计算所给出的天平是否平衡,条件是Wl * Dl = Wr * Dr, 0 表示节点,重量为下一层的Wl + Wr
解题思路:是一道二叉树的题目,但其实不需要建树,具体看代码吧。

#include<stdio.h>
int bo;
int DFS(){
int wl, dl, wr, dr;
scanf("%d%d%d%d", &wl, &dl, &wr, &dr);
if (wl == 0)
wl = DFS();
if (wr == 0)
wr = DFS();
if (wl * dl != wr * dr)
bo = 1;
return wr + wl;
}

int main(){
int t;
scanf("%d", &t);
while (t--){
bo = 0;
DFS();
if (bo)
printf("NO\n");
else
printf("YES\n");
if (t)
printf("\n");
}
return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: