您的位置:首页 > 其它

uva572 - Oil Deposits

2013-07-31 13:48 375 查看
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into
numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many
different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n,
the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 

 and 

.
Following this are m lines of n characters
each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@',
representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output 

0
1
2
2


这里就是个dfs,很简单,但这种思想要熟悉。
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

char str[105][105];

void dfs(int x,int y){
if(str[x][y]=='@'){
str[x][y]='*';
dfs(x-1,y-1); dfs(x-1,y); dfs(x-1,y+1);
dfs(x,y-1); dfs(x,y+1);
dfs(x+1,y-1); dfs(x+1,y); dfs(x+1,y+1);
}
else
return;
}

int main(){
int m,n,sum;
while(scanf("%d%d",&m,&n)==2&&m&&n){
getchar();
memset(str,0,sizeof(str));
for(int i=1;i<=m;i++)gets(&str[i][1]);
sum=0;
for(int i=1;i<=m;i++)
for(int j=1;j<=n;j++)
if(str[i][j]=='@'){
dfs(i,j);
sum++;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: