您的位置:首页 > 其它

uva 10025 The ? 1 ? 2 ? ... ? n = k problem(算式规律)

2013-07-31 10:20 417 查看


 The ? 1 ? 2 ? ... ? n = k problem 


The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 

with n = 7


The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.


The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.


Sample Input

2

12

-3646397



Sample Output

7

2701

题目大意:给出一个数, 判断它需要从1~m(可用+、-)填充的算式求得。求m
解题思路:首先, 1~m的和一定要 > n(如果全+都无法表示的话, 更别说有-)其次,找到一个m,使得1~m的和>n之后,因为sum >= n, 所以要减掉一个数, 比如在数字k前面加个-号, 相当于sum - 2 * k,也就是说每次减掉只能是偶数, 那么就要求sum % 2 == n % 2.(负数同理)

#include<stdio.h>

int main(){
int t, n, sum, i;
scanf("%d", &t);
while (t--){
scanf("%d", &n);
if (n < 0)
n = -n;
for (sum = 0, i = 1; ; i++){
sum += i;
if (sum >= n && (sum - n) % 2 == 0){
printf("%d\n", i);
break;
}
}
if (t)
printf("\n");
}
return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: