您的位置:首页 > 其它

POJ 1789 Truck History【最小生成树简单应用】

2013-07-31 09:52 465 查看

链接:

http://poj.org/problem?id=1789

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=22010#problem/G

Truck History

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14950 Accepted: 5714
Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase
letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types
were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that
the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output
The highest possible quality is 1/3.

Source

CTU Open 2003

题意:

                给你 N 个字符串,求串通他们的最小距离和

        每个字符串都只有 7 个字符
        两个字符串的距离就是数出对应位置不同的字符个数
         

算法:最小生成树

思路:

                 把每个字符串看成一个地点,字符串间不同的字符个数看成地点间的距离。套用最小生成树就好了

Kruskal:

1789Accepted22860K563MSC++1378B
//Accepted	22860 KB	579 ms	C++	1302 B	2013-07-31 09:37:35
#include<stdio.h>
#include<algorithm>
using namespace std;

const int maxn = 2000+10;
char map[maxn][10];
int p[maxn];
int n,m;

struct Edge{
int u,v;
int w;
}edge[maxn*maxn/2];

int dist(int st, int en)
{
int distance = 0;
for(int i = 0; i < 7; i++)
if(map[st][i] != map[en][i])
distance++;
return distance;
}

bool cmp(Edge a, Edge b)
{
return a.w < b.w;
}

int find(int x)
{
return x == p[x] ? x : p[x] = find(p[x]);
}

int Kruskal()
{
int ans = 0;
for(int i = 1; i <= n; i++) p[i] = i;
sort(edge,edge+m,cmp);

for(int i = 0; i < m; i++)
{
int u = find(edge[i].u);
int v = find(edge[i].v);

if(u != v)
{
p[v] = u;
ans += edge[i].w;
}
}
return ans;
}
int main()
{
while(scanf("%d", &n) != EOF)
{
if(n == 0) break;
for(int i = 1; i <= n; i++)
scanf("%s", map[i]);

m = 0;
for(int i = 1; i <= n; i++)
{
for(int j = i+1; j <= n; j++)
{
edge[m].u = i;
edge[m].v = j;
edge[m++].w = dist(i,j);
}
}

int ans = Kruskal();
printf("The highest possible quality is 1/%d.\n", ans);
}
return 0;
}


Prime:

Accepted15672K454MSC++1289B2013-07-31 09:38:56
//Accepted	15672 KB	469 ms	C++	1227 B	2013-07-31 09:37:25
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn = 2000+10;
const int INF = maxn*7;

char map[maxn][10];
int w[maxn][maxn];
int d[maxn];
int vis[maxn];
int n;

int dist(int st, int en)
{
int distance = 0;
for(int i = 0; i < 7; i++)
if(map[st][i] != map[en][i])
distance++;
return distance;
}

int Prime()
{
int ans = 0;
for(int i = 1; i <= n; i++) d[i] = INF;
d[1] = 0;
memset(vis, 0, sizeof(vis));

for(int i = 1; i <= n; i++)
{
int x, m = INF;
for(int y = 1; y <= n; y++) if(!vis[y] && d[y] <= m) m = d[x=y];
vis[x] = 1; ans += d[x];
for(int y = 1; y <= n; y++) if(!vis[y])
d[y] = min(d[y], w[x][y]);
}
return ans;
}
int main()
{
while(scanf("%d", &n) != EOF)
{
if(n == 0) break;

for(int i = 1; i <= n; i++) scanf("%s", map[i]);

for(int i = 1; i <= n; i++)
{
for(int j = i+1; j <= n; j++)
{
w[i][j] = dist(i,j);
w[j][i] = w[i][j];
}
}

int ans = Prime();
printf("The highest possible quality is 1/%d.\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: