您的位置:首页 > 其它

UVA 839 Not so Mobile

2013-07-31 00:37 337 查看


  Not so Mobile 
Before being an ubiquous communications gadget, a mobile was just a structure made of strings and wires suspending colourfull things. This kind of mobile is usually found hanging over cradles of small babies.



The figure illustrates a simple mobile. It is just a wire, suspended by a string, with an object on each side. It can also be seen as a kind of lever with the fulcrum on the point where the string ties the wire. From the lever principle we know that to balance
a simple mobile the product of the weight of the objects by their distance to the fulcrum must be equal. That is Wl×Dl = Wr×Dr where Dl is
the left distance,Dr is the right distance, Wl is the left weight and Wr is the right weight.

In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure. In this case it is not so straightforward to check if the mobile is balanced so we need you to write a program that, given a description of a mobile as input,
checks whether the mobile is in equilibrium or not.




Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank
line, and there is also a blank line between two consecutive inputs.

The input is composed of several lines, each containing 4 integers separated by a single space. The 4 integers represent the distances of each object to the fulcrum and their weights, in the format: Wl Dl Wr Dr

If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define the the sub-mobile. In this case we compute the weight of the sub-mobile
as the sum of weights of all its objects, disregarding the weight of the wires and strings. If both Wland Wr are zero then the following lines define two sub-mobiles:
first the left then the right one.


Output 

For each test case, the output must follow the description
below. The outputs of two consecutive cases will be separated by a blank line.

Write `YES' if the mobile is in equilibrium, write `NO' otherwise.


Sample Input 

1

0 2 0 4
0 3 0 1
1 1 1 1
2 4 4 2
1 6 3 2



Sample Output 

YES


题意:输入t表示有t个样例。然后输入w1 d1 w2 d2. 表示左边的权重和长度,右边的权重和长度。。
根据物理学0 0...w1 * d1 = w2 * d2 时候是能平衡的。。然后如果遇到w = 0的时候, 表示有子树。

并且他的权重是等于子树总重w1 + w2

然后要是不平衡就输入NO ,平衡输出YES
解法:

这题不需要建树。。只要模拟建树那个过程就OK了。。边建树边判断。。要注意。建树过程中即使不满足平衡,。也不能结束建树,一定要建完树最后输出。。。不然就错了。。本人因为这个WA了次。坑

#include <stdio.h>
#include <string.h>

int t;
int judge;
int quan;
void dfs()
{
//if (judge)
// return;
int w1, d1, w2, d2;
scanf("%d%d%d%d", &w1, &d1, &w2, &d2);
if (w1 == 0)
{
dfs();
w1 = quan;
}
if (w2 == 0)
{
dfs();
w2 = quan;
}
if (w1 * d1 != w2 * d2)
{
judge = 1;
return;
}
else
{
quan = w1 + w2;
}
}
int main()
{
scanf("%d", &t);
while (t --)
{
judge = 0;
dfs();
if (judge)
printf("NO\n");
else
printf("YES\n");
if (t)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: