您的位置:首页 > 其它

杭电1171-Big Event in HDU

2013-07-30 12:21 477 查看

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18268    Accepted Submission(s): 6400


[align=left]Problem Description[/align]
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and
Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50
--value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

 

[align=left]Output[/align]
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal
as possible. At the same time, you should guarantee that A is not less than B.

 

[align=left]Sample Input[/align]

2
10 1
20 1
3
10 1
20 2
30 1
-1

 

[align=left]Sample Output[/align]

20 10
40 40AC代码+解释:
#include<iostream>//这题利用母函数思想
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
const int MAX=100001;
int c1[MAX];//只要可以整除的都标记为1即初始可以组合的数,找出小于且最接近总和的一半的数组值为1的下标即为结果
using namespace std;
typedef struct Facility
{
int value;
int num;
}facility;
facility s[MAX];//注意这里是坑爹的地方,我就是没注意RE了2次,如果按照题目描述n只开1000的话,那必定RE,n至少要开到100000
int main()
{
int n,i,j,sum;
while(cin>>n,n>=0)
{
sum=0;
for(i=0;i<n;i++)
{
cin>>s[i].value>>s[i].num;
sum+=s[i].value*s[i].num;
}
for(i=0;i<=sum;i++)
{
if(i%s[0].value==0)//只要可以整除的都标记为1即初始可以组合的数
c1[i]=1;
else
c1[i]=0;
}
for(i=1;i<n;i++)
{
for(j=0;j<=sum/2;j++)
{
for(int k=0;k+j<=sum/2&&k<=s[i].value*s[i].num;k+=s[i].value)//用数组值0或1表示其下标是否是能组成,最后找出小于且最接近总和的一半的数组值为1的下标
{
if(c1[j]==1)
c1[k+j]=1;
}
}
}
for(j=sum/2;j>=0;j--)
{
if(c1[j]!=0)//找出小于且最接近总和的一半的数组值为1的下标即为结果索要求的
break;
}
cout<<sum-j<<" "<<j<<endl;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电1171-Big Event in