您的位置:首页 > 其它

hdu-1250-Hat's Fibonacci

2013-07-29 18:11 453 查看

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5640    Accepted Submission(s): 1873


[align=left]Problem Description[/align]
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.

F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)

Your task is to take a number as input, and print that Fibonacci number.

 

[align=left]Input[/align]
Each line will contain an integers. Process to end of file.

 

[align=left]Output[/align]
For each case, output the result in a line.
 

[align=left]Sample Input[/align]

100

 

[align=left]Sample Output[/align]

4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 

[align=left]Author[/align]
戴帽子的
 

[align=left]Recommend[/align]
Ignatius.L
代码:

import java.math.BigInteger;

import java.util.Scanner;

public class Main {

 /**

  * @param args

  */

 public static void main(String[] args) {

  // TODO Auto-generated method stub

  Scanner input=new Scanner(System.in);

  while(input.hasNext()){

   int n=input.nextInt();

   if(n==1||n==2||n==3||n==4){

    System.out.println(1);

   }

   else

   {

       BigInteger a=BigInteger.valueOf(1);

       BigInteger b=BigInteger.valueOf(1);

       BigInteger c=BigInteger.valueOf(1);

       BigInteger d=BigInteger.valueOf(1);

       BigInteger num=BigInteger.valueOf(0);

    for(int i=5;i<=n;i++)

    {

     num=a.add(b).add(c).add(d);

     a=b;

     b=c;

     c=d;

     d=num;

    }

    System.out.println(num);

   }

  }

  

 }

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: