您的位置:首页 > 产品设计 > UI/UE

HDU--杭电--1711--Number Sequence--KMP--水题,看毛片算法基础死方法运用

2013-07-29 10:51 447 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8126    Accepted Submission(s): 3688


[align=left]Problem Description[/align]
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

 

 

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

 

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

 

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 

 

[align=left]Sample Output[/align]

6
-1

 

#include <iostream>

#include <cstdio>

#include <cstring>
using namespace std;

int
next[11111],s1[1111111],s2[11111];

void
getnext(int s[],int l)  //求next数组

{

    int
i=0,j=-1;next[i]=j;

    while(
i<l)

        if(
j==-1||s[i]==s[j])next[++i]=++j;

        else
j=next[j];

}

int
KMP(int l1,int l2)  //匹配

{

    int
i=0,j=0;

    while(
i<l1&&j<l2)

        if(
j==-1||s1[i]==s2[j])i++,j++;

        else
j=next[j];

    if(
j==l2)return i-l2+1;

    return
0;

}

int main (void)

{

    int
t,i,n,m;

    cin>>t;

    while(
t--&&scanf("%d%d",&n,&m))

    {

        for(
i=0;i<n;i++)

            scanf("%d",&s1[i]);

        for(
i=0;i<m;i++)

            scanf("%d",&s2[i]);

        getnext(s2,m);i=KMP(n,m);

        if(
i)printf("%d\n",i);

        else
printf("-1\n");

    }

    return
0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: