您的位置:首页 > 大数据 > 人工智能

HDU--杭电--4300--Clairewd’s message--KMP--KMP的灵活运用

2013-07-29 10:40 393 查看

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2564    Accepted Submission(s): 1006


[align=left]Problem Description[/align]
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another
one according to a conversion table.

Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action,
she just stopped transmitting messages.

But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering
the shortest possible text is not a hard task for you.

Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.

 

 

[align=left]Input[/align]
The first line contains only one integer T, which is the number of test cases.

Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the
text is complete.

Hint
Range of test data:

T<= 100 ;

n<= 100000;

 

 

[align=left]Output[/align]
For each test case, output one line contains the shorest possible complete text.
 

 

[align=left]Sample Input[/align]

2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde

 

 

[align=left]Sample Output[/align]

abcdabcd
qwertabcde

 

#include <iostream>

#include <cstdio>

#include <cstring>
using namespace std;

int
next[111111];

char
a[333],s[111111],ss[55555];

void
getnext(int l)  //求next数组

{

    int
i=0,j=-1;next[i]=j;

    while(
i<l)

        if(
j==-1||s[i]==s[j])next[++i]=++j;

        else
j=next[j];

}

int
kmp(char s1[],char s2[],int
l1,int l2)  //用s2匹配s1

{

    int
i=0,j=0;

    while(
i<l1&&j<l2)

        if(
j==-1||s1[i]==a[s2[j]])i++,j++;

        else
j=next[j];

    return
j;  //返回s2已经匹配的后一个下标

}

int main (void)

{

    int
n,i,k,l;

    char
c;

    scanf("%d%*c",&n);

    while(
n--)

    {


        memset(next,0,sizeof(next));

        for(
i='a';i<='z';i++)

            scanf("%c",&c),a[c]=i;

        getchar();

        scanf("%s%*c",s);

        l=strlen(s);

        strcpy(ss,s+(l+1)/2); 
//把后一半可能带有密文的明文装入ss


        getnext(l);  //求输入的密文明文混合体的next

        k=kmp(ss,s,strlen(ss),l); 
//得到匹配成功的长度,即里面存在的明文的长度


        i=l;l-=2*k;

        while(
l--)

        {


            s[i]=a[s[k]];

            i++;k++;

        }


        s[i]='\0';

        puts(s);

    }

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: