您的位置:首页 > 其它

poj1860 bellman 最短路

2013-07-29 09:24 411 查看
Currency Exchange

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16184 Accepted: 5626
Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing
in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected
in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain
6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104.

Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output
YES

最短路!

#include<iostream>
using namespace std;
int n;     //货币种数
int m;     //兑换点数量
int s;     //持有第s种货币
double v;  //持有的s货币的本金
int all;  //边总数
double dis[101];  //s到各点的权值
class exchange_points
{
public:
int a;      //货币a
int b;      //货币b
double r;   //rate
double c;   //手续费
}exc[202];
bool bellman(void)
{
memset(dis,0,sizeof(dis));      //这里与bellman的目的刚好相反。初始化为源点到各点距离无穷小
dis[s]=v;                       //即bellman本用于找负环,求最小路径,本题是利用同样的思想找正环,求最大路径

/*relax*/
bool flag;
for(int i=1;i<=n-1;i++)
{
flag=false;
for(int j=0;j<all;j++)
if(dis[exc[j].b] < (dis[exc[j].a] - exc[j].c) * exc[j].r)         //寻找最长路径
{                                                                 //进行比较的是"某点到自身的权值"和"某点到另一点的权值"
dis[exc[j].b] = (dis[exc[j].a] - exc[j].c) * exc[j].r;
flag=true;
}
if(!flag)
break;
}

/*Search Positive Circle*/

for(int k=0;k<all;k++)
if(dis[exc[k].b] < (dis[exc[k].a] - exc[k].c) * exc[k].r)           //正环能够无限松弛
return true;

return false;
}

int main(void)
{
int a,b;
double rab,cab,rba,cba;   //临时变量

while(cin>>n>>m>>s>>v)
{
all=0;    //注意初始化
for(int i=0;i<m;i++)
{
cin>>a>>b>>rab>>cab>>rba>>cba;
exc[all].a=a;
exc[all].b=b;
exc[all].r=rab;
exc[all++].c=cab;
exc[all].a=b;
exc[all].b=a;
exc[all].r=rba;
exc[all++].c=cba;
}

/*Bellman-form Algorithm*/
if(bellman())
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: