您的位置:首页 > 其它

杭电1133-Buy the Ticket

2013-07-28 17:53 204 查看

Buy the Ticket

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3598    Accepted Submission(s): 1514


[align=left]Problem Description[/align]
The "Harry Potter and the Goblet of Fire" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won't be stopped from the first person till the last person.

Note: initially the ticket-office has no money.

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.

 

[align=left]Input[/align]
The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.

 

[align=left]Output[/align]
For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.

 

[align=left]Sample Input[/align]

3 0
3 1
3 3
0 0

 

[align=left]Sample Output[/align]

Test #1:
6
Test #2:
18
Test #3:
180AC代码+解释:
#include<iostream>
#include<cstdio>
#include<cstring>//又一个经典的卡特兰数的应用:50元的数量永远不小于100元的数量,m和n最大均为100,第200位卡特兰数是373位
#include<string>
#include<algorithm>
const int MAX=501;
int s[MAX];
using namespace std;
int main()
{
int n,m,q,p=1,c,sum,k,temp,t,i,j;
while(cin>>m>>n&&(m||n))
{
cout<<"Test #"<<p++<<':'<<endl;
if(m<n)//如果m<n那么永远没有方法所以输出0
{
cout<<0<<endl;
continue;
}
memset(s,0,sizeof(s));
s[1]=1;
sum=0;
for(i=2;i<=(m+n);i++)//处理好(n+m)的阶层,如果不懂原理的可以去做HDOJ上的1042题
{
for(j=1;j<MAX;j++)
{
c=s[j]*i+sum;
s[j]=c%10;
sum=c/10;
}
}
q=m+1-n;
sum=0;
for(j=1;j<MAX;j++)
{
c=s[j]*q+sum;
s[j]=c%10;
sum=c/10;
}
for(j=MAX-1;j>=1;j--)
{
if(s[j]!=0)
break;
}
for(i=j;i>=1;i--)
for(i=j,sum=0,t=0;i>=1;i--)
{
temp=sum*10+s[i];
if(t==0)//处理好前导零
{
if(temp/(m+1)>0)
{
t=1;
cout<<temp/(m+1);
}
}
else
cout<<temp/(m+1);
sum=temp%(m+1);
}
cout<<endl;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电1133-Buy the Ticke