您的位置:首页 > 其它

uva 340 Master-Mind Hints(检索)

2013-07-28 14:55 387 查看


 Master-Mind Hints 
MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that
a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code 

 and a guess 

 ,
and are to determine the hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i,j), 

 and 

 ,
such that 

 . Match (i,j) is called strong when i = j, and is called weakotherwise.
Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independentwhen all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that
these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.


Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range
1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum
value for N will be 1000.


Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game
should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.


Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0



Sample Output

Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)

题目大意:给出多个序列,求后面的序列与第一个序列   相同列且数值相同的个数   和  两行在不同列相同数字的个数。
解题思路:只要遍历一次,记录相同数字的总数,和相同列上相同数字的个数就可以了,  不同列相同的数字就是两个的差。

#include<stdio.h>
#include<string.h>
#define N 1005
#define M 15
#define min(a, b) a > b? b : a

int num

;
int vis[M], tem
;

int main(){
int n, bo, cnt, ti = 1;

while (scanf("%d", &n), n){
// Init.
memset(num, 0, sizeof(num));
memset(tem, 0, sizeof(tem));
bo = 1;
cnt = 0;

// Read.
while (bo){
for (int i = 0; i < n; i++){
scanf("%d", &num[cnt][i]);
if (num[cnt][i] == 0)
bo = 0;
if (cnt == 0)
tem[num[0][i]]++;
}
cnt++;
}

// Printf.
printf("Game %d:\n", ti++);
for (int i = 1; i < cnt - 1; i++){
memset(vis, 0, sizeof(vis));
int so = 0, fo = 0;

for (int j = 0; j < n; j++){
if (num[i][j] == num[0][j])
so++;
vis[num[i][j]]++;
}

for (int j = 1; j <= 9; j++)
fo += min(tem[j], vis[j]);

printf("    (%d,%d)\n", so, fo - so);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: