您的位置:首页 > 理论基础 > 数据结构算法

Hdoj1879继续畅通工程

2013-07-28 13:38 246 查看
Hdoj1879:


继续畅通工程

Problem Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。

 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。

 

Output

每个测试用例的输出占一行,输出全省畅通需要的最低成本。

 

Sample Input

3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0

 

Sample Output

3
1
0

 

Author

ZJU

 

Source

浙大计算机研究生复试上机考试-2008年

 

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
struct node{
int x,y,cost,f;
bool operator<(const node&p)const{
if(f!=p.f) return f>p.f;
return cost<p.cost;
}
}q[5000];
int N,p[101],ans,cot;
int fin(int x)
{
return p[x]==x?x:fin(p[x]);
}
void join(int i)
{
int f1=fin(q[i].x);
int f2=fin(q[i].y);
if(f1!=f2)
{
p[f1]=f2;
cot--;
if(!q[i].f)
ans+=q[i].cost;
}
}
int main()
{
while(scanf("%d",&N)&&N)
{
cot=N-1;
for(int i=1;i<=N;i++)
p[i]=i;
int m=N*(N-1)/2;
for(int i=0;i<m;i++)
scanf("%d %d %d %d",&q[i].x,&q[i].y,&q[i].cost,&q[i].f);
sort(q,q+m);
ans=0;
for(int i=0;i<m;i++){
if(!cot)
break;
join(i);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU 数据结构 并查集