您的位置:首页 > 理论基础 > 数据结构算法

Hdoj1875畅通工程再续

2013-07-28 13:35 429 查看
Hdoj1875:


畅通工程再续

Problem Description

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。

 

Input

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。

每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。

 

Output

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.

 

Sample Input

2
2
10 10
20 20
3
1 1
2 2
1000 1000

 

Sample Output

1414.2
oh!

 

Author

8600

 

Source

2008浙大研究生复试热身赛(2)——全真模拟

 

Recommend

lcy

 

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
struct node{
int x,y;
double cost;
bool operator<(const node &q)const{
return cost<q.cost;
}
}a[5000];
int n,p[101],cot,q[101][2];
double ans;
int fid(int x)
{
return p[x]==x?x:fid(p[x]);
}
void join(int x,int y,int c)
{
int f1=fid(x);
int f2=fid(y);
if(f1!=f2)
{
cot--;
ans+=a[c].cost;
p[f1]=f2;
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
ans=0.0;
scanf("%d",&n);
cot=n-1;
for(int i=0;i<n;i++)
p[i]=i;
for(int i=0;i<n;i++)
scanf("%d %d",&q[i][0],&q[i][1]);
int k=0;
for(int i=0;i<n;i++)
for(int j=i+1;j<n;j++)
{
int tmp=(q[i][0]-q[j][0])*(q[i][0]-q[j][0])+(q[i][1]-q[j][1])*(q[i][1]-q[j][1]);
if(tmp>=100&&tmp<=1000000)
{
a[k].x=i;
a[k].y=j;
a[k++].cost=sqrt((double)tmp);
}
}
sort(a,a+k);
for(int i=0;i<k;i++)
join(a[i].x,a[i].y,i);
if(cot)
printf("oh!\n");
else
printf("%.1lf\n",ans*100);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU 数据结构 并查集