您的位置:首页 > 其它

POJ 1308 Is It A Tree?

2013-07-27 15:06 225 查看
[align=center]Is It A Tree?[/align]

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18569 Accepted: 6342
Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist
of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source
North Central North America 1997
 
题意:
每组数据以一对0 0结束,整个程序以一对-1 -1结束
每一对数字x y代表有一条有向边由x指向y,问题是,给出的数据是否构成一颗树

代码:
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<string>
#define MAX 110000

int point[MAX];     //point[i]记录点i是否被记录过
int common_p[MAX];  //common_p[i]记录某点的入度,因为为有向图,若入度大于1,则不成立
int point_num;      //记录所有点的个数
int edge_num;       //记录所有边的个数

int main()
{
int a,b;
int Case=1;
bool is_tree;

while(scanf("%d%d",&a,&b) && a>=0 && b>=0)
{
memset(point,0,sizeof(point));
memset(common_p,0,sizeof(common_p));
point_num=0; edge_num=0;
is_tree=true;

while(a || b)
{
edge_num++;
if(is_tree)
{
if(common_p[b])
is_tree=false;
common_p[b]++;

if(point[a]==0)
{
point[a]=1;
point_num++;
}

if(point[b]==0)
{
point[b]=1;
point_num++;
}
}
scanf("%d%d",&a,&b);
}

if(point_num==0) point_num=1;  //空树的情况

if(is_tree && point_num==edge_num+1)  //构成树的点数等于边数加1
printf("Case %d is a tree.\n",Case++);
else printf("Case %d is not a tree.\n",Case++);
}
return 0;
}

/*并查集*/

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#define MAX 10005

typedef struct
{
int x,y;
}edge;

edge e[MAX];
int father[MAX];
int vis[MAX];
int max_point;

void init()
{
for(int i=0;i<=MAX;i++)
{
father[i]=i;
vis[i]=0;
}
}

int Find(int i)
{
while(father[i]!=i)
i=father[i];
return i;
}

void Union(int x,int y)
{
if(x>y) father[y]=x;
else father[x]=y;
}

int main()
{
int a,b;
int Case=1;

while(scanf("%d%d",&a,&b))
{
if(a==-1 && b==-1) break;
if(!a && !b)
{
printf("Case %d is a tree.\n",Case++);
continue;
}

init();

int root=0;
max_point=0;

vis[a]=vis[b]=1;
if(max_point<a) max_point=a;
if(max_point<b) max_point=b;
int x=Find(a);
int y=Find(b);
if(x!=y) Union(x,y);
else root++;

while(scanf("%d%d",&a,&b) && (a || b))
{
vis[a]=vis[b]=1;
if(max_point<a) max_point=a;
if(max_point<b) max_point=b;
int x=Find(a);
int y=Find(b);
if(x!=y) Union(x,y);
else root++;
}

for(int i=1;i<=max_point;i++)
if(vis[i] && father[i]==i) root++;
if(root==1) printf("Case %d is a tree.\n",Case++);
else printf("Case %d is not a tree.\n",Case++);
}
return 0;
}


思路:
法一:
若出现多点指向一点(某点入度数大于1)或点数不等于边数加1的情况,则不成立
法二:
若出现多个根节点的情况则不成立
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: