您的位置:首页 > 其它

hdu 1004 Let the Balloon Rise

2013-07-27 10:04 399 查看


Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 57537    Accepted Submission(s): 21029


Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

 

Sample Output

red
pink

 

Author

WU, Jiazhi

 

Source

ZJCPC2004

 

Recommend

JGShining

import java.util.HashMap;
import java.util.Scanner;

public class Main{
public static void main(String[] args) {
Scanner input=new Scanner(System.in);
while(true){
int max=-1;
String s="";
HashMap<String, Integer> map=new HashMap<String, Integer>();
int n=input.nextInt();
if(n==0)
break;
for(int i=0;i<n;i++){
String a=input.next();
if(map.get(a)!=null){
int e=map.get(a)+1;
map.put(a, e);
if(max<e){
max=e;
s=a;
}
}
else{
map.put(a, 1);
if(max<1){
max=1;
s=a;
}
}
}
System.out.println(s);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HashMap hdu