您的位置:首页 > 其它

uva 350 Pseudo-Random Numbers(模拟)

2013-07-26 15:30 483 查看


 Pseudo-Random Numbers 
Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many
applications, including simulation.

A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating ( 

 ,
where Z is a constant multiplier, Iis a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed) is
4, then we can determine the next few pseudo-random numbers are follows:



As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M.

In this problem you will be given sets of values for Z, I, M, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers
that will be generated. But be careful: the cycle might not begin with the seed!


Input

Each input line will contain four integer values, in order, for Z, I, M, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M.


Output

For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.


Sample Input

7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0



Sample Output

Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220

题目大意:给出z、l、m、i,根据公式l = (z * l + i ) % m,问l形成的循环有多少数。
解题思路:形成的循环不一定包含原先的l(测试数据貌似没有卡这点,但是做的时候考虑到了),所以开个数组num
,将当前l,num[l]=cnt(计数器),如过num[l]被赋值,循环的个数即为cnt + 1 - num[l].

#include<stdio.h>
#include<string.h>
#define N 100000
int num
;
int main(){
int z, i, m, l, k;
int cnt, ti = 1;
while (scanf("%d%d%d%d", &z, &i, &m, &l) != EOF && z && i && m && l){
cnt = 1;
memset(num, 0, sizeof(num));
num[l] = 1;
do{
l = (z * l + i) % m;
if (num[l] != 0)
break;
else
num[l] = ++cnt;
}while (1);
printf("Case %d: %d\n", ti++, ++cnt - num[l]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: