您的位置:首页 > 其它

POJ 2777 Count Color (线段树&位运算)

2013-07-26 11:28 260 查看
Count Color

http://poj.org/problem?id=2777

Time Limit: 1000MS Memory Limit: 65536K

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment
with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.

2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the
beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation
defined previously.
Output

Ouput results of the output operation in order, each line contains a number.
Sample Input
2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2


Sample Output
2
1


注意A可以大于B。

/*360ms,2800KB*/

#include <cstdio>
#include <algorithm>
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
#define root 1, N, 1
const int maxn = 100000;

int sum[maxn << 2], add[maxn << 2];

inline void up(int rt)
{
	sum[rt] = sum[rt << 1] | sum[rt << 1 | 1];
}

inline void down(int rt)
{
	if (add[rt])
	{
		add[rt << 1] = add[rt << 1 | 1] = add[rt];
		sum[rt << 1] = sum[rt << 1 | 1] = add[rt];
		add[rt] = 0;
	}
}

void update(int ql, int qr, int c, int l, int r, int rt)
{
	if (ql <= l && r <= qr)
	{
		add[rt] = c;
		sum[rt] = c;
		return;
	}
	down(rt);
	int m = (l + r) >> 1;
	if (ql <= m) update(ql, qr, c, lson);
	if (qr > m) update(ql, qr, c, rson);
	up(rt);
}

int query(int ql, int qr, int l, int r, int rt)
{
	if (ql <= l && r <= qr)
	{
		return sum[rt];
	}
	down(rt);
	int m = (l + r) >> 1;
	int ret = 0;
	if (ql <= m) ret |= query(ql, qr, lson);
	if (qr > m) ret |= query(ql, qr, rson);
	return ret;
}

inline int cnt(int val)
{
	int n = 0;
	while (val)
	{
		if (val & 1) n++;
		val >>= 1;
	}
	return n;
}

int main()
{
	int N, Q, a, b, c;
	scanf("%d%*d%d", &N, &Q);
	fill(sum + 1, sum + (N << 2), 1);
	while (Q--)
	{
		getchar();
		if (getchar() == 'P')
		{
			scanf("%d%d", &a, &b);
			if (a > b) swap(a, b);
			printf("%d\n", cnt(query(a, b, root)));
		}
		else
		{
			scanf("%d%d%d", &a, &b, &c);
			if (a > b) swap(a, b);
			update(a, b, 1 << (c - 1), root);
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: