您的位置:首页 > 其它

UVA 10115 Automatic Editing

2013-07-25 22:41 344 查看


Problem E: Automatic Editing

Source file:autoedit.{c, cpp, java, pas}
Input file:autoedit.in
Output file:autoedit.out
Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within
a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.banbab
2.bababe
3.anaany
4.ba bhind the g
To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by thereplace-by string, then try to perform the same replacement again on the new text. Continue
until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a findstring, you always start searching at the beginning of the
text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and
then rule 4 was used once.

 BeforeAfter
banana boatbabana boat
babana boatbababa boat
bababa boatbeba boat
beba boatbehind the goat
The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines,
where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-bystrings may be empty (indicated in the input file by an empty line). During the edit process
the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0


Example output:

behind the goat
shoe or shop


替换字符串。要注意。一定要替换到不能替换为止。。

用strstr妥妥过。。。

#include <stdio.h>
#include <string.h>

int n;
char a[105][105];
char b[105][105];
char sb[305];

int main()
{
while (scanf("%d", &n) != EOF && n)
{
getchar();
for (int i = 0; i < n; i ++)
{
gets(a[i]);
gets(b[i]);
}
gets(sb);
for (int i = 0; i < n ; i++)
{
while (strstr(sb, a[i]) != NULL)
{
char *p;
char t[305];
p = strstr(sb, a[i]);
strcpy(t, p + strlen(a[i]));
strcpy(p, b[i]);
strcpy(p + strlen(b[i]), t);
}
}
printf("%s\n", sb);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: