您的位置:首页 > 其它

uva 10034 Freckles(最小生成树Kruskal)

2013-07-25 01:37 471 查看

Freckles

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one
of the freckles turns out to be a scar, so his Ripley's engagement falls through.

Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the
pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.


Input

The input begins with a single positive integer on a
line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.


Output

For each test case, the output must follow the description
below. The outputs of two consecutive cases will be separated by a blank line.

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.


Sample Input

1

3
1.0 1.0
2.0 2.0
2.0 4.0



Sample Output

3.41


#include<string.h>
#include<algorithm>
#include<math.h>
#include<stdio.h>
using namespace std;

#define N 105

struct dis{
double lenth;
int a;
int b;
};

struct coor{
double x;
double y;
};

int cmp(const dis &a, const dis &b)
{
return a.lenth < b.lenth;
}

int num
;

int get_fa(int x)
{
return num[x] != x? get_fa(num[x]):x;
}

double count_dis(coor a, coor b)
{
return sqrt( pow( a.x - b.x, 2) + pow (a.y - b.y, 2));
}

int main()
{
int k;

scanf("%d", &k);

while (k--)
{
int n;
scanf("%d", &n);
coor t
;

// Init.
for (int i = 0; i < n; i++)
num[i] = i;
int cnt = 0;
double sum = 0;
dis l[N * N];

// Read.
for (int i = 0; i < n; i++)
scanf("%lf%lf", &t[i].x, &t[i].y);

// Count.
for (int i = 0; i < n; i++)
for (int j = i + 1; j < n; j++)
{
l[cnt].lenth= count_dis(t[i], t[j]);
l[cnt].a = i;
l[cnt].b = j;
cnt++;
}

sort(l, l + cnt, cmp);

for (int i = 0; i < cnt; i++)
{
if (get_fa(l[i].a) == get_fa(l[i].b))
continue;
sum += l[i].lenth;
num[get_fa(l[i].a)] = get_fa(l[i].b);
}

printf("%.2f\n", sum);

if(k)
printf("\n");

}
return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: