您的位置:首页 > 产品设计 > UI/UE

poj 2524 Ubiquitous Religions

2013-07-25 00:00 225 查看
摘要: 第二道并查集;貌似比1611TheSuspects还要水;没什么难度,同样没用rank优化,1A~

/*
Ubiquitous Religions
Time Limit: 5000MS  Memory Limit: 65536K
Total Submissions: 20194  Accepted: 9918

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different
religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore,
many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them
whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes
in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes
to at most one religion.
Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j,
specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the
university believe in.
Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.
Source

Alberta Collegiate Programming Contest 2003.10.18
*/

#include <cstdio>
#include <cstdlib>
using namespace std;

int fa[50005] = {0};

int getfa(int x)
{
if(fa[x] == x) return x;
else return getfa(fa[x]);
}

void join(int x, int y)
{
int s = getfa(x);
int t = getfa(y);
if(s != t)
{
fa[t] = s;
}
return;
}

int main()
{
int m = 0, n = 0, a = 0, b = 0;
int casenum = 0;
while(scanf("%d%d", &n, &m) && !(m == 0 && n == 0))
{
casenum++;
for(int i = 0; i < n; ++i) fa[i] = i;
for(int i = 0; i < m; ++i)
{
scanf("%d%d", &a, &b);
join(a, b);
}
int sum_ = 0;
for(int i = 0; i < n ; ++i)//计数
{
if(fa[i] == i) sum_++;
}
printf("Case %d: %d\n", casenum, sum_);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj cpp