您的位置:首页 > 其它

uva 10010 Where's Waldorf?(DFS字符串查找)

2013-07-24 23:26 337 查看


Where's Waldorf? 
Given a m by n grid
of letters, ( 

),
and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be
treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.


Input 

The input begins with a single positive integer on a
line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The input begins with a pair of integers, m followed by n, 

 in decimal notation on a single line.
The next m lines contain n letters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integer k appears on
a line by itself ( 

). The next k lines of input contain the list of words to search for, one word per line.
These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).


Output 

For each test case, the output must follow the description
below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where the first letter of the given
word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid,
and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of
the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.


Sample Input 

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert



Sample Output 

2 5
2 3
1 2
7 8

题目大意:给出一个网状字符串组,查找所给的字符串,输出第一个字符的坐标(可以向八个方向延伸)
解题思路:DFS。

#include<iostream>
#include<string.h>
using namespace std;

#define N 55

char map

;
char tem
;
int n, m;
int dir[8][2] = {{1, 1}, {1, 0}, {0, 1}, {1, -1}, {-1, 1}, {-1, 0}, {0, -1},
{-1, -1}};

void strl(char str[])
{
int k = strlen(str);
for (int i = 0; i < k; i++)
if (str[i] >= 'a' && str[i] <= 'z')
str[i] -=32;
}

int judge(char str[], int a, int b)
{
int k = strlen(str);
int bo;
for (int i = 0; i < 8; i++)
{
bo = 0;
for (int j = 1; j < k; j++)
{
if (a + dir[i][0] * j >= n || a + dir[i][0] * j < 0)
{
bo = 1;
break;
}
if (b + dir[i][1] * j >= m || b + dir[i][1] * j < 0)
{
bo = 1;
break;
}
if (str[j] != map[a + dir [i][0] *j][b + dir[i][1] * j])
{
bo = 1;
break;
}
}

if (bo) continue;
return 1;
}
return 0;
}

void find(char str[])
{
for (int i = 0; i < n; i++)
for (int j = 0; j < m; j++)
if (str[0] == map[i][j] && judge(str, i, j))
{
cout << i + 1 << " " << j + 1 << endl;
return;
}
}

int main()
{
int t;

cin >> t;
while (t--)
{
// Init.
memset(map, 0, sizeof(map));
memset(tem, 0, sizeof(tem));

// Read.
cin >> n >> m;
for (int i = 0; i < n; i++)
{
cin >> map[i];
strl(map[i]);
}

// Print.
int k;
cin >> k;
for (int i = 0; i < k; i++)
{
cin >> tem;
strl(tem);
find(tem);
memset(tem, 0, sizeof(tem));
}
if (t)
cout << endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: