您的位置:首页 > 其它

POJ 1200 Hash

2013-07-24 16:42 435 查看
Crazy Search

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 20460 Accepted: 5790

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon
will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed
16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4

daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source

Southwestern Europe 2002

题意:从一字符串中找具有N个长度的但不相同的子串的个数,条件是给出的字符串是NC进制的

思路:在NC进制下,如果两数不相同,那么在其他进制下,两数也不相同,所有可以把原串转换以十进制方法来求

首先对原串中的字符按ASC大小赋予初值 ,可以从0开始,那样较好算

代码:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
#include <map>
#define M 20000006
using namespace std;
char a[M];
bool vis[M];
int asc[256];
int main()
{
int n,nc;
scanf("%d%d",&n,&nc);
//getchar();
scanf("%s",a);
int len=strlen(a);
for(int i=0;i<len;i++)
{
asc[a[i]]=1;
}
int s=0,sum=0;
for(int i=0;i<256;i++)
{
if(asc[i])asc[i]=s++;
}
for(int i=0;i<len-n+1;i++)
{
int ret=0;
for(int j=0;j<n;j++)
ret=ret*nc+asc[a[i+j]];
if(!vis[ret])sum++;
vis[ret]=true;
}
printf("%d\n",sum);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: