您的位置:首页 > 其它

杭电1856-More is better

2013-07-23 17:16 211 查看

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 9803    Accepted Submission(s): 3611


[align=left]Problem Description[/align]
Mr Wang wants some boys to help him with a project. Because the project is rather complex,
the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

[align=left]Input[/align]
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated
by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

 

[align=left]Output[/align]
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

 

[align=left]Sample Input[/align]

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

 

[align=left]Sample Output[/align]

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
又是一道并查集题目AC代码+详细解释:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
const int MAX=10000001;
int father[MAX];//父节点
int friend_X[MAX];//朋友数
int Max;//最大朋友数
using namespace std;
void init()
{
int i;
for(i=1;i<MAX;++i)
father[i]=i,friend_X[i]=1;//朋友数初始化都是1
}
int find_father(int x)//这里用递归省时,因为用while会超时,因为条件给的范围是一千万
{
if(x!=father[x])//寻找父节点
father[x]=find_father(father[x]);
return father[x];
/*while(x!=father[x])//这里超时过一次,以后碰到数据大的最好不要用while
{
x=father[x];
}
return x;*/
}
void join_tree(int x,int y)
{
int a,b;
a=find_father(x);
b=find_father(y);
if(a!=b)
{
father[a]=b;//把新的子节点并进父节点
friend_X[b]+=friend_X[a];//每次父节点都加上新的子节点的朋友数
if(friend_X[b]>Max)//挑选最大的父节点朋友数
Max=friend_X[b];
}
}
int main()
{
int t,x,y,sum;
while(cin>>t)
{
init();
Max=1;//这里初始化是1不是0,因为当输入时0时,输出是1,就是这样我WA了一次
while(t--)
{
cin>>x>>y;
join_tree(x,y);//每次更新节点
}
cout<<Max<<endl;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电1856-More is bette