您的位置:首页 > 大数据 > 人工智能

POJ 2709 Painter

2013-07-23 17:08 197 查看
[align=center]Painter[/align]

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2691 Accepted: 1689
Description
The local toy store sells small fingerpainting kits with between three and twelve 50ml bottles of paint, each a different color. The paints are bright and fun to work with, and have the useful property that if you mix X ml each
of any three different colors, you get X ml of gray. (The paints are thick and "airy", almost like cake frosting, and when you mix them together the volume doesn't increase, the paint just gets more dense.) None of the individual colors are gray; the only
way to get gray is by mixing exactly three distinct colors, but it doesn't matter which three. Your friend Emily is an elementary school teacher and every Friday she does a fingerpainting project with her class. Given the number of different colors needed,
the amount of each color, and the amount of gray, your job is to calculate the number of kits needed for her class.
Input
The input consists of one or more test cases, followed by a line containing only zero that signals the end of the input. Each test case consists of a single line of five or more integers, which are separated by a space. The first
integer N is the number of different colors (3 <= N <= 12). Following that are N different nonnegative integers, each at most 1,000, that specify the amount of each color needed. Last is a nonnegative integer G <= 1,000 that specifies the amount of gray needed.
All quantities are in ml.

Output
For each test case, output the smallest number of fingerpainting kits sufficient to provide the required amounts of all the colors and gray. Note that all grays are considered equal, so in order to find the minimum number of kits
for a test case you may need to make grays using different combinations of three distinct colors.
Sample Input
3 40 95 21 0
7 25 60 400 250 0 60 0 500
4 90 95 75 95 10
4 90 95 75 95 11
5 0 0 0 0 0 333
0

Sample Output
2
8
2
3
4

Source
Mid-Central USA 2005
 
题意:
一套颜料中有3~12种颜色,每种颜色有50ml。先除现有颜色外,还需要指定量的灰色颜料。已知等体积三种颜料搭配可调出相同体积的灰色颜料,问共需要买多少套颜料。
 
代码:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define N 15

int color
;
int n;

int cmp(const void *a,const void *b)
{
return *(int *)a-*(int *)b;
}

int main()
{
int i,gray,ans,max;

while(scanf("%d",&n)!=EOF && n)
{
for(i=0;i<n;i++)
scanf("%d",&color[i]);
scanf("%d",&gray);

qsort(color,n,sizeof(int),cmp);

ans=0; max=0;
while(max<color[n-1])     //不考虑gray时所需的颜料数
{
max+=50;
ans++;
}

while(true)
{
while(color[2]<max && gray>0)   //考虑用剩余颜料调出灰色颜料
{
color[0]++;
color[1]++;
color[2]++;
gray--;

qsort(color,n,sizeof(int),cmp);
}
if(gray==0) break;
else
{
max+=50;
ans++;
}
}

printf("%d\n",ans);
}
return 0;
}


思路:
先求出不考虑灰色颜料时需买的颜料套数,再用剩余颜料一毫升一毫升折算为灰色颜料,不够则加一套即可。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: