您的位置:首页 > 其它

hdu 3342 Legal or Not(拓扑排序dfs)

2013-07-23 16:54 429 查看


Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3021    Accepted Submission(s): 1370


Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions,
many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too
many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian
is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

 

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and
y is x's prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

 

Output

For each test case, print in one line the judgement of the messy relationship.

If it is legal, output "YES", otherwise "NO".

 

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

 

Sample Output

YES
NO
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int map[105][105],vis[105],N,M;
bool dfs(int u)
{
vis[u]=-1;//值为-1,当前正在访问的
for(int v=0;v<N;v++)
if(map[u][v])
{
if(vis[v]<0)  return false;//存在环路,又搜到自己
if(vis[v]&&!dfs(v))  return false;//vis[v]=0;说明这个点还没搜,可以尽心后面的深搜。
//深搜返回真值,说面里面的点已经搜过了。
}
vis[u]=1; return true;
}
bool toposort()
{
memset(vis,0,sizeof(vis));
for(int u=0;u<N;u++)
if(!vis[u])
if(!dfs(u))  return false;
return true;
}
int main()
{
int a,b;
while(scanf("%d %d",&N,&M),N,M)
{
memset(map,0,sizeof(map));
for(int i=0;i<M;i++)
{
scanf("%d %d",&a,&b);
map[a][b]=1;
}
if(!toposort())  printf("NO\n");
else printf("YES\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: