您的位置:首页 > 其它

杭电1213-How Many Tables

2013-07-23 14:11 281 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9135    Accepted Submission(s): 4472


[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the
friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000).
N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

[align=left]Sample Output[/align]

2
4基础并查集,这题也是小鱼的第一道并查集题,好像是一遍过了,嘿嘿....AC代码和详细解释,如果不懂并查集可以看看这个:点击打开链接(不懂并查集看看,保证有用!!!)里面把并查集一些基础知识通俗化了,很容易就看得懂!
#include<iostream>
#include<cstdio>
#include<cstring>
const int MAX=1001;
int father[MAX];
int n;
int m;
using namespace std;
void init()//初始化
{
int i;
for(i=0;i<=n;++i)
father[i]=i;
}
int find_father(int x)//寻找父节点即最初的节点
{
while(x!=father[x])
{
x=father[x];
}
return x;
}
void join_tree(int x,int y)//将新的节点加入并查集中
{
int a,b;
a=find_father(x);
b=find_father(y);
if(a!=b)
father[a]=b;
}
int main()
{
int t,a,b,i,sum;
cin>>t;
while(t--)
{
cin>>n>>m;
sum=0;
init();
while(m--)
{
cin>>a>>b;
join_tree(a,b);
}
for(i=1;i<=n;i++)
if(father[i]==i)//如果一个节点的父节点是他自己表明多需要一张桌子
sum+=1;
cout<<sum<<endl;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电1213-How Many Tabl