您的位置:首页 > 其它

hdu4465 Candy

2013-07-22 16:40 211 查看
Candy
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and
the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.

He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
 

Input

There are several test cases.

For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).

Input is terminated by EOF.
 

Output

For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.

Any answer with an absolute error less than or equal to 10-4 would be accepted.
 

Sample Input

10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520
2276 0.720000

 

Sample Output

Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816
Case 6: 1390.500000这题的公式不好推导,在这里,我们可以用快速的组合公式,这一点很重要,而且由于数据太大,只能用log了!
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
double nlogn[400005];
double fc(int m,int n)
{
return (nlogn[m]-nlogn
-nlogn[m-n]);
}
int main()
{
int tcase,i,n;
double p,q,sum,temp;
nlogn[0]=0;
for(i=1;i<=400000;i++)
{
nlogn[i]=nlogn[i-1]+log(i);
}
tcase=1;
while(scanf("%d%lf",&n,&p)!=EOF)
{
q=log(1-p);//保存起来,以后就不用多次算了
p=log(p);
sum=0;
for(i=0;i<n;i++)
{
temp=fc(n+i,i);
sum+=(n-i)*(exp(temp+(n+1)*p+i*q)+exp(temp+(n+1)*q+i*p));
}
printf("Case %d: %.6f\n",tcase++,sum);
}
return 0;
}


 

FAQ | About Virtual Judge | Forum | Discuss | Open
Source Project

All Copyright Reserved ©2010-2012 HUST ACM/ICPC TEAM 

Anything about the OJ, please ask in the forum, or contact author:Isun

Server Time: 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu4465 Candy