您的位置:首页 > 其它

HDU1258 Sum It Up

2013-07-21 09:33 330 查看

                                                          
Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2966    Accepted Submission(s): 1483


[align=left]Problem Description[/align]
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2,
and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

 

[align=left]Input[/align]
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise,
t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order,
and there may be repetitions.

 

[align=left]Output[/align]
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order.
A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums
with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

 

[align=left]Sample Input[/align]

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

 

[align=left]Sample Output[/align]

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

 

[align=left]Source[/align]
浙江工业大学第四届大学生程序设计竞赛

 

[align=left]Recommend[/align]
JGShining

解题思路:本题属于深度优先搜索题,搜索思维简单,得出答案不难,难点在于判重。把所有的可能的结果都求出来,再判重明显是不现实的,超时是必然结果,也给码代码的同学很大一难题。只要在搜索时,对于每个子搜索,它的起点不一样,那么,后面的值便不可能完全一样,自然也就达到了排重的目的。

#include<cstdio>
#include<cstring>
using namespace std;
int m,n,f;
int sum;
int a[13],now[13];
void dfs(int start,int i)
{
int j;
if(sum>m)
return ;
if(sum==m)
{
f=1;
printf("%d",now[0]);
for(j=1;j<i;j++)
printf("+%d",now[j]);
printf("\n");
return ;
}
int temp=-1;      //每次起点值都不同,直接避免重复
for(j=start+1;j<=n;j++)
{
if(a[j]!=temp)
{
temp=a[j];
sum+=a[j];
now[i]=a[j];
dfs(j,i+1);
sum-=a[j];
}
}
}
int main()
{
int i;
while(scanf("%d%d",&m,&n)&&n||m)
{
f=0;
sum=0;
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
printf("Sums of %d:\n",m);
dfs(0,0);
if(!f)
printf("NONE\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: