您的位置:首页 > 其它

uva 575 Skew Binary(模拟)

2013-07-20 21:39 531 查看
When a number is expressed in decimal, the k-th digit represents a multiple of 10k. (Digits are numbered from right to left,
where the least significant digit is number 0.) For example,



When a number is expressed in binary, the k-th digit represents a multiple of 2k. For example,



In skew binary, the k-th digit represents a multiple of 2k+1 - 1. The only possible digits are 0
and 1, except that the least-significant nonzero digit can be a 2. For example,



The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry.
However, this has nothing to do with the current problem.)

Input 

The input file contains one or more lines, each of which contains an integer n. If n = 0 it signals the end of the input, and otherwise nis a nonnegative
integer in skew binary.

Output 

For each number, output the decimal equivalent. The decimal value of n will be at most 231 - 1 = 2147483647.

Sample Input 

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0

Sample Output 

44
2147483646
3
2147483647
4
7
1041110737

题目大意:根据公式求值。
解题思路:模拟公式,大水题一道。

#include<iostream>
#include<string.h>
using namespace std;

int main()
{
char str[100];

while(1)
{
cin >> str;
int n = strlen(str);

if (n == 1 && str[0] == '0')
break;

int sum = 0;
int t = 2;
int a;

do{
a = str[n - 1] - '0';
sum = sum + (t - 1) * a;
t *= 2;
n--;
}while (n != 0);

cout << sum << endl;
memset(str, 0, sizeof(str));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: