您的位置:首页 > 其它

POJ 2352 线段树方法

2013-07-20 19:12 267 查看
Stars

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 26354Accepted: 11498
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source

Ural Collegiate Programming Contest 1999

同样的题,不同的方法,上次是用树状数组,这次线段数。

怎么说呢,虽然线段数在树状数组能应用的领域都比不上树状数组,但是它能解决树状数组不能解决的问题,所以我还是学习一下,进过一下午的努力,终于写出了我的第一个线段数。觉得也不是想象的那么难,主要记住三个步骤:建树、查询、跟新,然后就ok了。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
    int left,right,value;
}tree[32000*4+5];
int n,x,y;
int level[32005];
void create(int l,int r,int root)
{
    tree[root].left=l;
    tree[root].right=r;
    tree[root].value=0;
    if(l==r)return;
    else
    {
        int m=(l+r)/2;
        create(l,m,root*2);
        create(m+1,r,root*2+1);
    }
}
int query(int x,int root)
{
    if(tree[root].left==x&&tree[root].right==x)return tree[root].value;
    else
    {
        int m=(tree[root].left+tree[root].right)/2;
        if(x<=m)return tree[root].value+query(x,root*2);
        else return tree[root].value+query(x,root*2+1);
    }
}
void update(int l,int r,int root)
{
    if(tree[root].left==l&&tree[root].right==r)
    {
        tree[root].value++;
        return ;
    }
    int m=(tree[root].left+tree[root].right)/2;
    if(r<=m)update(l,r,root*2);
    else if(l>m)update(l,r,root*2+1);
    else
    {
        update(l,m,root*2);
        update(m+1,r,root*2+1);
    }
}
int main()
{
    scanf("%d",&n);
    create(0,32000,1);
    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&x,&y);
        level[query(x,1)]++;
        update(x,32000,1);
    }
    for(int i=0;i<n;i++)cout<<level[i]<<endl;
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: