您的位置:首页 > 其它

POJ 1080 Human Gene Functions

2013-07-20 16:56 381 查看
[align=center]Human Gene Functions[/align]

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15468 Accepted: 8585
Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining
their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.

One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many
researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.

Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments
will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity

of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of

the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal

length. These two strings are aligned:

AGTGAT-G

-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.



denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG

-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the

similarity of the two genes is 14.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence.
The length of each gene sequence is at least one and does not exceed 100.
Output
The output should print the similarity of each test case, one per line.
Sample Input
2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA

Sample Output
14
21

Source
Taejon 2001
 
题意:
求两个已知碱基序列的最大相似度
 
代码:
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<string>
#include<algorithm>
#define MAX 102
using namespace std;

int dp[MAX][MAX];
int table['T'+1]['T'+1];

void init()
{
table['A']['A']=5;
table['A']['C']=-1;
table['A']['G']=-2;
table['A']['T']=-1;
table['A']['-']=-3;

table['C']['A']=-1;
table['C']['C']=5;
table['C']['G']=-3;
table['C']['T']=-2;
table['C']['-']=-4;

table['G']['A']=-2;
table['G']['C']=-3;
table['G']['G']=5;
table['G']['T']=-2;
table['G']['-']=-2;

table['T']['A']=-1;
table['T']['C']=-2;
table['T']['G']=-2;
table['T']['T']=5;
table['T']['-']=-1;

table['-']['A']=-3;
table['-']['C']=-4;
table['-']['G']=-2;
table['-']['T']=-1;
table['-']['-']=-1e9;
}

int main()
{
int t,len1,len2;
int i,j;
char s1[MAX],s2[MAX];

init();

while(scanf("%d",&t)!=EOF)
{
while(t--)
{
scanf("%d%s",&len1,s1+1);
scanf("%d%s",&len2,s2+1);
memset(dp,0,sizeof(dp));
for(i=1;i<=len1;i++)
dp[i][0]=dp[i-1][0]+table[s1[i]]['-'];
for(i=1;i<=len2;i++)
dp[0][i]=dp[0][i-1]+table['-'][s2[i]];
for(i=1;i<=len1;i++)
for(j=1;j<=len2;j++)
dp[i][j]=max(dp[i-1][j-1]+table[s1[i]][s2[j]],max(dp[i-1][j]+table[s1[i]]['-'],dp[i][j-1]+table['-'][s2[j]]));
printf("%d\n",dp[len1][len2]);
}
}
return 0;
}


思路:
×设两个DNA序列分别为s1,s2,长度分别为len1,len2,score为分值表。
   f[i,j]表示子串s1[1..i]和s2[1..j]的分值。考虑一个f[i,j],我们有:
  1.s1取第i个字母,s2取“-”:f[i-1,j] + table[s1[i],'-']
  2.s1取“-”,s2取第j个字母:f[i,j-1] + table['-',s2[j]]
  3.s1取第i个字母,s2取第j个字母:f[i-1,j-1] + table[s1[i],s2[j]]
  即f[i,j] = max(f[i-1,j] + table[s1[i],'-'], f[i,j-1] + table['-',s2[j]], f[i-1,j-1] + table[s1[i],s2[j]]);
×初始化操作中:
  当i=j=0时,即为f[0,0],这是在计算f[1,1]时用到的,根据f[1,1] = f[0,0] + score[s1[i], s2[j]],明显有f[0,0] = 0。

  当i=0时,即为f[0,1..len2],有了f[0,0],可以用f[0,j] = f[0,j-1] + table['-',s2[j]]来计算。

  当j=0时,即为f[1..len1,0],有了f[0,0],可以用f[i,0] = f[i-1,0] + table[s1[i],'-']来计算。
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: