您的位置:首页 > 其它

POJ 2255 Tree Recovery

2013-07-20 12:09 246 查看
Description
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

D

/ \

/   \

B     E

/ \     \

/   \     \

A     C     G

/

/

F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF
and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input
The input will contain one or more test cases.

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD

Sample Output
ACBFGED
CDAB


树的构建,及遍历。开始按部就班,先把树构建出来,再后序遍历。后来在算法入门经典里面看见一个很给力的代码(至少比我得给力)。俩个都AC了。

复杂代码:构建了完整的树

#include<iostream>
#include<stdio.h>
using namespace std;
typedef struct BiTNode{
char data;
struct BiTNode*lchild,*rchild;
} BiTNode,*BiTree;

void CreateTree(BiTree &T,string pre,string ino){
int pos,len;
len=pre.size();
if(len==0)
T=NULL;
else{
pos=ino.find(pre[0]);
if(pos==-1)
T=NULL;
else{
T=new BiTNode;
T->data=pre[0];
if(pos==0)
T->lchild=NULL;
else
CreateTree(T->lchild,pre.substr(1,pos),ino.substr(0,pos));
if(pos==len-1)
T->rchild=NULL;
else
CreateTree(T->rchild,pre.substr(pos+1),ino.substr(pos+1));
}
}
}
void print(BiTree T){
if(T==NULL)
return;
print(T->lchild);
print(T->rchild);
cout<<T->data;
}

int main(){
char s1[1000],s2[1000];
BiTree T;
while(scanf("%s%s",s1,s2)!=EOF){
CreateTree(T,s1,s2);
print(T);
cout<<endl;
}
return 0;
}


简单代码: 是边构建边输出后序

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

void search(int n,char *s1,char *s2){
if(n<=0) return ;
int p=strchr(s2,s1[0])-s2;
search(p,s1+1,s2);
search(n-p-1,s1+p+1,s2+p+1);
printf("%c",s1[0]);
}
int main(){
char s1[1008],s2[1008];
while(~scanf("%s%s",&s1,&s2)){
int n=strlen(s1);
search(n,s1,s2);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: