您的位置:首页 > 其它

DFS Sum It Up

2013-07-18 16:03 211 查看
HDU 1258 Sum It Up

http://acm.hdu.edu.cn/showproblem.php?pid=1258

Sum It Up

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2927 Accepted Submission(s): 1468


[align=left]Problem Description[/align]
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

[align=left]Input[/align]
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

[align=left]Output[/align]
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

[align=left]Sample Input[/align]

4 6 4 3 2 2 1 1

5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

[align=left]Sample Output[/align]

Sums of 4:
4

3+1

2+2

2+1+1
Sums of 5:
NONE

Sums of 400:
50+50+50+50+50+50+25+25+25+25

50+50+50+50+50+25+25+25+25+25+25

[align=left]Source[/align]
浙江工业大学第四届大学生程序设计竞赛

这题搞了一个晚上,不过一直没搞出来,后来看了一下别人AC代码,然后自己写了一个,写的有点丑,不过这代码对于重判处理的还是很好的。

#include<stdio.h>
int t,n,a[100],ans[100],flag;
void dfs(int i,int j,int k)//i是a数组的下标,j是记录数组的下标,k就是和
{
int p;
int pre=-1;
if(k==t)
{
flag=1;
for(p=0;p<j;p++)
printf("%d%c",ans[p],p==j-1?'\n':'+');
return ;
}
for(p=i;p<n;p++)
{
//printf("a[%d]=%d\n",p,a[p]);
if(k+a[p]>t)
continue;
if(a[p]!=pre)
{
pre=a[p];
ans[j]=a[p];
dfs(p+1,j+1,k+a[p]);
}
}
return;
}
int main()
{
int i;
while(scanf("%d %d",&t,&n)!=EOF)
{
flag=0;
if(n==0)
break;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
printf("Sums of %d:\n",t);
dfs(0,0,0);
if(!flag)
printf("NONE\n");

}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: