您的位置:首页 > 其它

hdu 3535 AreYouBusy[各种分组背包]

2013-07-18 14:35 465 查看

AreYouBusy

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2332 Accepted Submission(s): 869



[align=left]Problem Description[/align]
Happy New Term!

As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.

What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define
the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be
a good junior(which means that she should follow the boss's advice)?

[align=left]Input[/align]
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers
m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi
follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

[align=left]Output[/align]
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

[align=left]Sample Input[/align]

3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10


[align=left]Sample Output[/align]

5
13
-1
-1


题目:http://acm.hdu.edu.cn/showproblem.php?pid=3535

首先题目给了很多类别的物品。用 数组dp[i][j],表示第i组,时间为j时的快乐值。每得到一组工作就进行一次DP,所以dp[i]为第i组的结果。

第一类,至少选一项,即必须要选,那么在开始时,对于这一组的dp的初值,应该全部赋为负无穷(或者-1,只要每次更新时判断一下即可),这样才能保证不会出现都不选的情况。

状态转移方程: dp[i][k]=max(dp[i][k],max(dp[i-1][k-c[j]]+v[j],dp[i][k-c[j]]+v[j]));

第二类,最多选一项,即如果选必定是第一次选只能有dp[i-1][]转化而来

要保证全局最优 ,应把上组的dp[i-1][]值赋给本组,作为本组的初始化

状态转移方程: dp[i][k]=max(dp[i][k],dp[i-1][k-c[j]]+v[j]);

第三类:自由选,无限制 要保证全局最优必然要把上组dp[i-1][]值赋给本组,作为本组的初始化

状态转移的时候只需从本组转移

状态转移方程: dp[i][k]=max(dp[i][k],dp[i][k-c[j]]+v[j]);

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define N 105
using namespace std;
int c
,v
;
int n,t,m,s;
int dp

;
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d%d",&n,&t)!=EOF)
{
memset(dp[0],0,sizeof(dp[0]));
for(int i=1; i<=n; i++)
{
scanf("%d%d",&m,&s);
for(int j=0; j<m; j++)
scanf("%d%d",&c[j],&v[j]);
if(s==0)
{
memset(dp[i],-1,sizeof(dp[i]));//本组初始化
for(int j=0; j<m; j++)
for(int k=t; k>=c[j]; k--)
if(dp[i-1][k-c[j]]!=-1||dp[i][k-c[j]]!=-1)//注意由于有可能c[j]==0,!!!!
dp[i][k]=max(dp[i][k],max(dp[i-1][k-c[j]]+v[j],dp[i][k-c[j]]+v[j]));

}
else if(s==1)
{
for(int p=0; p<=t; p++)
dp[i][p]=dp[i-1][p];
for(int j=0; j<m; j++)
for(int k=t; k>=c[j]; k--)
if(dp[i-1][k-c[j]]!=-1)
dp[i][k]=max(dp[i][k],dp[i-1][k-c[j]]+v[j]);
}
else if(s==2)
{
for(int p=0; p<=t; p++)
dp[i][p]=dp[i-1][p];
for(int j=0; j<m; j++)
for(int k=t; k>=c[j]; k--)
if(dp[i][k-c[j]]!=-1)
dp[i][k]=max(dp[i][k],dp[i][k-c[j]]+v[j]);
}
}
printf("%d\n",dp
[t]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: