您的位置:首页 > 其它

HDU2717 Catch That Cow

2013-07-18 11:05 197 查看

                                                        
Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4945    Accepted Submission(s): 1567


[align=left]Problem Description[/align]
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer
John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

[align=left]Input[/align]
Line 1: Two space-separated integers: N and K
 

[align=left]Output[/align]
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

[align=left]Sample Input[/align]

5 17

 

[align=left]Sample Output[/align]

4

HintThe fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

[align=left]Source[/align]
USACO 2007 Open Silver

 

[align=left]Recommend[/align]
teddy

解题思路,直接广度优先搜索,搜索方向作变动,有传统的4个相邻方向变成一维相邻,或飞跃。注意空间的大小,别爆栈或超内存。

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int map[1000000];
int flood[1000000];
int dir[2]={1,-1};
int n,s,e;
struct node
{
int x;
int step;
};
int bfs()
{
node now,next;
queue<node> q;
now.x=s;
now.step=0;
flood[s]=1;
if(e==s)
return 0;
q.push(now);
while(!q.empty())
{
now=q.front();
q.pop();
for(int i=0;i<2;i++)      //往上或往下一层
{
next.x=now.x+dir[i];
next.step=now.step+1;
if(next.x>=0&&next.x<1000000&&!flood[next.x])
{
if(next.x==e)
return next.step;
flood[next.x]=1;
q.push(next);
}
}
next.x=now.x*2;      //飞跃到2*x点去
next.step=now.step+1;
if(next.x>=0&&next.x<1000000&&!flood[next.x]) //不要爆栈
{
if(next.x==e)
return next.step;
flood[next.x]=1;
q.push(next);
}
}
return -1;
}
int main()
{
int i;
while(scanf("%d%d",&s,&e)!=EOF)
{
memset(flood,0,sizeof(flood));
printf("%d\n",bfs());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: