您的位置:首页 > 其它

HDU--1213--How Many Tables--并查集

2013-07-18 08:40 561 查看

How Many Tables

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9066    Accepted Submission(s): 4429
[/b]

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

 

[align=left]Sample Output[/align]

2
4

 

#include <iostream>
using namespace std;
int father[1111];	//把每个点集看成家族,代表集合的点看成祖先,用fahter标记
int Find(int a)	//查找祖先
{
if(father[a]==a)	//如果a是祖先
return a;	//返回a
int k=Find(father[a]);	不然递归下去找他father的祖先
father[a]=k;	//并把a的father指向本家族的祖先,这样在下次查找时可以节省时间
return k;	//返回祖先
}
void Union(int a,int b)
{
int x,y;
x=Find(a);	//x和y分别找到a和b的祖先
y=Find(b);
if(x!=y)	//如果不是同一个家族
father[x]=Find(y);	//那么合并,也就是一个祖先当另一个祖先的孙子^^
}
int main (void)
{
int t,n,m,i,j,k,l;
cin>>t;
while(t--&&cin>>n>>m)
{
for(i=1;i<=n;i++)
father[i]=i;	//首先每个点是自己独立的家族的祖先
for(i=0;i<m;i++)
{
cin>>k>>l;
Union(k,l);	//合并k和l所在的家族
}
for(i=1,j=0;i<=n;i++)
if(father[i]==i)	//查看祖先个数,因为每个家族只有一个祖先,家族数就是集合数
{
j++;
}
cout<<j<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: