您的位置:首页 > 其它

Hdu 1536 S-Nim

2013-07-17 19:29 429 查看

S-Nim

[align=center]Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others
[/align]

[align=left]Problem Description[/align]
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.

It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.

Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove
a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position.
This means, as expected, that a position with no legal moves is a losing position.
 

[align=left]Input[/align]
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0
< m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by
a 0 on a line of its own.
 

[align=left]Output[/align]
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.

 

[align=left]Sample Input[/align]

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

 

[align=left]Sample Output[/align]

LWW
WWL

 

[align=left]Source[/align]
Norgesmesterskapet 2004

SG函数+组合游戏定理

#include<cstdio>
#include<cstring>

int num[110];
int SG[11000];
int k;

void dfs(int x)
{
int i;
int vis[110];
memset(vis,0,sizeof(vis));
for(i=1;i<=k;i++)
{
if(x-num[i]>=0)
{
if(SG[x-num[i]]==-1)
dfs(x-num[i]);
vis[SG[x-num[i]]]=1;
}
}

for(i=0;i<110;i++)
{
if(vis[i]==0)
{
SG[x]=i;
return ;
}
}
}

int main()
{
int t,x,flag,n;
int i;

while(scanf("%d",&k),k)
{
for(i=1;i<=k;i++)
{
scanf("%d",&num[i]);
}

memset(SG,-1,sizeof(SG));
scanf("%d",&t);
while(t--)
{
flag=0;
scanf("%d",&n);
SG[0]=0;
for(i=1;i<=n;i++)
{
scanf("%d",&x);
if(SG[x]==-1)
dfs(x);
flag^=SG[x];
}
if(flag==0)
printf("L");
else
printf("W");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: