您的位置:首页 > 其它

uva 101 The Blocks Problem(模拟)

2013-07-16 18:29 471 查看


  The Blocks Problem 


Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning
and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.


The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there
are n blocks on the table (numbered from 0 to n-1)
with block bi adjacent
to block bi+1 for
all 

 as
shown in the diagram below:

 

Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:
move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a andb to their initial positions.

move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their
initial positions.

pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above blocka, onto block b. All blocks on top of
block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b.
The blocks stacked above block a retain their original order when moved.

quit
terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.


The Input 

The input begins with an integer n on
a line by itself representing the number of blocks in the block world. You may assume that 0 <n <
25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.


The Output 

The output should consist of the final state of the blocks world. Each original block position numbered i ( 

 where n is
the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other
block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).


Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit



Sample Output 

0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:


题目大意:1,move onto将a,b上的积木清空,然后将a放在b上。

  2,move over将a上的积木清空,然后将a放在b的最上方。

3,pile onto 将b上的积木清空,然后将a和a上的积木放在b上。

4,pile over将a和上的积木放在b的随上方。

注意:a和b同一个积木堆时,任何操做都时无效的。

解题思路:模拟。

#include<stdio.h>
#include<string.h>
#define M 5
#define N 26

int x, y, p, q;
int map

;
int n;

void find_go(int k)
{
for(int i = 0; i < n; i++)
for(int j = 1; map[i][j]; j++)
if(map[i][j] == k)
{
x=i;
y=j;
return;
}
}

void find_come(int k)
{
for(int i = 0; i < n; i++)
for(int j = 1; map[i][j]; j++)
if(map[i][j] == k)
{
p=i;
q=j;
return;
}
}

void re_move(int k)
{
if(k == 26)
map[0][1] = k;
else
map[k][1] = k;
}

void clear(int a, int b)
{
for(int i = 1; map[a][b+i]; i++)
{
re_move(map[a][b+i]);
map[a][b+i] = 0;
}
}

int main()
{
while(scanf("%d",&n) == 1)
{
// Init.
memset(map, 0, sizeof(map));
for(int i = 0; i < n; i++)
map[i][0] = map[i][1] = i;
map[0][1] = 26;

// Read.
char str[M];
int a,b;

while(scanf("%s", str), strcmp(str, "quit"))
{
if(strcmp(str, "move") == 0)
{
scanf("%d%s%d", &a, str, &b);

if(a == 0)	a = 26;
if(b == 0)  b = 26;

find_go(a);
find_come(b);
if(x == p)	continue;
clear(x, y);

if(strcmp(str, "onto") == 0)
{
clear(p, q);
map[p][q+1] = map[x][y];
map[x][y] = 0;
}
else
{
int i;
for(i = 1; map[p][q+i]; i++);
map[p][q+i] = map[x][y];
map[x][y] = 0;
}
}
else
{
scanf("%d%s%d", &a, str, &b);
if(a == 0)	a = 26;
if(b == 0)	b = 26;

find_go(a);
find_come(b);

if(x == p) continue;

if(strcmp(str, "onto") == 0)
{
clear(p, q);

for(int i = 0; map[p][q+i]; i++)
{
map[p][q+i+1] = map[x][y+i];
map[x][y+i] = 0;
}
}
else
{
int i;

for(i = 1; map[p][q+i]; i++);
for(int j = 0; map[x][y+j]; j++, i++)
{
map[p][q+i] = map[x][y+j];
map[x][y+j] = 0;
}
}
}
}

//Cout.
for(int i = 0;i < n; i++)
{
printf("%d:",i);

for(int j = 1; map[i][j]; j++)
{
if(map[i][j] == 26)
printf(" 0");
else
printf(" %d", map[i][j]);
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: