您的位置:首页 > 其它

HDOJ1348凸包模版

2013-07-16 15:01 239 查看
题目:题目链接

[align=left]Problem Description[/align]
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's
proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than
a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once
a plan of the wall listing the exact amount of resources that are needed to build the wall.

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.



The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely
measured the coordinates of all castle's vertices in feet.

[align=left]Input[/align]
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <=
1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides
of the castle do not intersect anywhere except for vertices.

[align=left]Output[/align]
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements.
You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger
error in the estimates.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 
[align=left]Sample Input[/align]

1

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

 
[align=left]Sample Output[/align]

1628

这道题...拿一根绳子把城堡圈起来,求这根绳子的长度...凸包,模版:

#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <iostream>

using namespace std;

const int N = 1005;
const double PI = 3.1415927;

struct point
{
double x;
double y;
} p
, stack
;

double dis(point A, point B)
{
return sqrt((A.x-B.x)*(A.x-B.x)+(A.y-B.y)*(A.y-B.y));
}

double crossProd(point A, point B, point C)
{
return (B.x-A.x)*(C.y-A.y) - (B.y-A.y)*(C.x-A.x);
}

//以最左下的点为基准点,其他各点(逆时针方向)以极角从小到大的排序规则
int cmp(const void *a, const void *b)
{
point *c = (point *)a;
point *d = (point *)b;
double k = crossProd(p[0], *c, *d);//极角大小转化为求叉乘
if (k<0 || !k && dis(p[0], *c)>dis(p[0], *d)) return 1;
return -1;
}

double Graham(int n)
{
double x = p[0].x;
double y = p[0].y;
int mi = 0;
for (int i=1; i<n; ++i)  //找到最左下的一个点
{
if (p[i].x<x || (p[i].x==x && p[i].y<y))
{
x = p[i].x;
y = p[i].y;
mi = i;
}
}
point tmp = p[mi];
p[mi] = p[0];
p[0] = tmp;
qsort(p+1, n-1, sizeof(point), cmp);
p
= p[0];
stack[0] = p[0];
stack[1] = p[1];
stack[2] = p[2];
int top = 2;
for (int i=3; i<=n; ++i)  //加入一个点后,向右偏拐或共线,则上一个点不在凸包内,则--top,该过程直到不向右偏拐或没有三点共线的点
{
while (crossProd(stack[top-1], stack[top], p[i])<=0 && top>=2) --top;
stack[++top] = p[i];//在当前情况下符合凸包的点,入栈
}
double len = 0;
for (int i=0; i<top; ++i)
len += dis(stack[i], stack[i+1]);
return len;
}

int main()
{
int t;
while (scanf("%d", &t) != EOF)
{
while (t--)
{
int n, l;
scanf ("%d%d", &n, &l);
for (int i=0; i<n; ++i)
scanf ("%lf%lf", &p[i].x, &p[i].y);
double ans = Graham(n);
ans += PI * (l + l);
printf ("%.0lf\n", ans);
if (t) printf ("\n");
}
}
return 0;
}


努力努力...
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  凸包 几何