您的位置:首页 > 其它

优先队列模拟最大堆和最小堆,poj 1442 Black Box

2013-07-16 10:49 309 查看
Black Box

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5619 Accepted: 2265
Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions).
There are two types of transactions:

ADD (x): put element x into Black Box;

GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1
N Transaction i Black Box contents after transaction Answer

(elements are arranged by non-descending)

1 ADD(3)      0 3

2 GET         1 3                                    3

3 ADD(1)      1 1, 3

4 GET         2 1, 3                                 3

5 ADD(-4)     2 -4, 1, 3

6 ADD(2)      2 -4, 1, 2, 3

7 ADD(8)      2 -4, 1, 2, 3, 8

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8

9 GET         3 -1000, -4, 1, 2, 3, 8                1

10 GET        4 -1000, -4, 1, 2, 3, 8                2

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8


It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.

Let us describe the sequence of transactions by two integer arrays:

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.

Input
Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output
3
3
1
2

Source
Northeastern Europe 1996
 
题目链接:http://poj.org/problem?id=1442
 
 
 
/*
题意:按顺序输入一些数(add),对应以后的每次get操作,第i次get x的意思是在输入的前x个数里找到第i小的数
分析:数据很复杂,要求对每次get进行高效的回应,选择用堆来做,建立一个最大堆和一个最小堆,最大堆里放前i-1小的数,最小堆里放剩下的;
于是要求的第i小的数就是最小堆的堆顶元素。
注意:动态维护。每次先把数据放进最小堆里,然后动态维护最小堆的堆顶要比最大堆的堆顶还要大。然后看是否达到get的数值,是,则输出,然后转移给最大堆元素达到i-1个。
*/
#include<cstdio>
#include<queue>
#include<iostream>
#include<functional>//用仿函数greater<> 要用这个头文件
#define max 30005
using namespace std;
priority_queue<long, vector<long>, greater<long> > min_heap;//优先队列里用仿函数,成最小堆。
priority_queue<long> max_heap;
long add[max],Get[max];
int main()
{
int M,N;
while(~scanf("%d %d",&M,&N)){
for(int i=1;i<=M;i++)
scanf("%ld",&add[i]);
for(int i=1;i<=N;i++)
scanf("%ld",&Get[i]);
int flag=1;
Get[0]=0;
for(int i=1;i<=M;i++)
{
min_heap.push(add[i]);//先放入最小堆
if(!max_heap.empty())
{
if(max_heap.top()>min_heap.top())
/*最大堆的堆顶比最小堆的堆顶大时,把最小堆的堆顶放到最大堆里,再把最大堆新的堆顶放到最小堆里,保证与最初的定义不矛盾*/
{
max_heap.push(min_heap.top());
min_heap.pop();
min_heap.push(max_heap.top());
max_heap.pop();
}
}
while(Get[flag]==(min_heap.size()+max_heap.size()))//达到get的时间时输出最小堆的堆顶
{
printf("%ld\n",min_heap.top());
flag++;//flag表示题目中的i的含义
while(max_heap.size()<flag-1)//保证最大堆里有flag-1个元素。
{
max_heap.push(min_heap.top());
min_heap.pop();
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息