您的位置:首页 > 其它

Pearls(ACM三部曲一)

2013-07-15 11:48 197 查看
Pearls

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 20000/10000K
(Java/Other)

Total Submission(s) : 15 Accepted Submission(s) : 8

Problem Description

In Pearlania everybody is fond of pearls. One company, called The
Royal Pearl, produces a lot of jewelry with pearls in it. The Royal
Pearl has its name because it delivers to the royal family of
Pearlania. But it also produces bracelets and necklaces for
ordinary people. Of course the quality of the pearls for these
people is much lower then the quality of pearls for the royal
family.In Pearlania pearls are separated into 100 different quality
classes. A quality class is identified by the price for one single
pearl in that quality class. This price is unique for that quality
class and the price is always higher then the price for a pearl in
a lower quality class.

Every month the stock manager of The Royal Pearl prepares a list
with the number of pearls needed in each quality class. The pearls
are bought on the local pearl market. Each quality class has its
own price per pearl, but for every complete deal in a certain
quality class one has to pay an extra amount of money equal to ten
pearls in that class. This is to prevent tourists from buying just
one pearl.

Also The Royal Pearl is suffering from the slow-down of the global
economy. Therefore the company needs to be more efficient. The CFO
(chief financial officer) has discovered that he can sometimes save
money by buying pearls in a higher quality class than is actually
needed.No customer will blame The Royal Pearl for putting better
pearls in the bracelets, as long as the

prices remain the same.

For example 5 pearls are needed in the 10 Euro category and 100
pearls are needed in the 20 Euro category. That will normally cost:
(5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20
Euro category only costs: (5+100+10)*20 = 2300 Euro.

The problem is that it requires a lot of computing work before the
CFO knows how many pearls can best be bought in a higher quality
class. You are asked to help The Royal Pearl with a computer
program.

Given a list with the number of pearls and the price per pearl in
different quality classes, give the lowest possible price needed to
buy everything on the list. Pearls can be bought in the
requested,or in a higher quality class, but not in a lower
one.

Input

The first line of the input contains the number of test cases. Each
test case starts with a line containing the number of categories c
(1<=c<=100). Then, c lines follow,
each with two numbers ai and pi. The first of these numbers is the
number of pearls ai needed in a class (1 <= ai
<= 1000).

The second number is the price per pearl pi in that class (1
<= pi <= 1000). The qualities of the
classes (and so the prices) are given in ascending order. All
numbers in the input are integers.

Output

For each test case a single line containing a single number: the
lowest possible price needed to buy everything on the list.

Sample Input

2

2

100 1

100 2

3

1 10

1 11

100 12

Sample Output

330

1344

Source

PKU

又是一道动态规划,ms很久以前就A过了。

思路:给出几类珍珠,以及它们的单价,要求用最少的钱就可以买到相同数量的,相同(或更高)质量的珍珠,规定买任一类的珍珠n个(价格为p),都要支付(n+10)*p的钱,即额外支付10*p。

本题关键点在于:

(1) 要求要买的珍珠的数量是一定的

(2) 所买的珍珠的质量允许提高,但不允许下降(即可以用高质量珍珠替代低质量)

(3) 输入时,后输入的珍珠价格一定比前面输入的要贵

(4)
由(2)(3)知,珍珠的替代必须是连续的,不能跳跃替代(这个不难证明,因为假如用第i+2类去替代第i类珍珠,会使最终的支付价格降低,那么用第i+1类去替代第i类珍珠会使最终的支付价格更加低)

令dp[i]表示在已知第i类珍珠时,所需支付的最低价,则状态方程为:dp[i]=(a[i]+10)*p[i]+dp[i-1];
//当第i种珍珠出现时,未优化价格的情况,dp[i]=min(dp[i],(sum[i]-sum[j]+10)*p[i]+dp[j]);
//枚举j,价格优化

c++ source code:

#include <iostream>

#include <cstdio>

#include <cstring>

int cmp (int x,int y)

{

if (x>y) return y;

else return x;

}

int main()

{

int t,n,a[2000],p[2000],dp[2000],sum[2000];

int i,j,k,l;

scanf("%d", &t);

for (i=1;i<=t;i++)

{

memset(dp, 0,sizeof(dp));

sum[0]=0;

scanf("%d", &n);

for (j=1;j<=n;j++)

{

scanf("%d%d", &a[j], &p[j]);

sum[j] = sum[j-1] + a[j];

dp[j] = (sum[j]+10) * p[j];

}

for (j=1;j<=n;j++)

{

for (k=1;k<=j;k++)

{

dp[j] = cmp(dp[j],(sum[j]-sum[k] +10) * p[j]+dp[k]);

}

}

printf("%d\n", dp
);

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: