您的位置:首页 > 其它

pku 3264 Balanced Lineup ( rmq or 线段树 )

2013-07-14 16:25 239 查看
Balanced Lineup

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 27941Accepted: 13120
Case Time Limit: 2000MS
Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range
of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest
cow in the group.

Input

Line 1: Two space-separated integers, N and Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i

Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output
6
3
0

Source

USACO 2007 January Silver
题意:给出n个高度,求一个区间的最大差值

题解:可以用2棵线段树,一棵保存最大值,一棵保存最小值,结果就是相减.

也可以用rmq做,也是一个dp区间保存最大值,另一个保存最小值.

//segememt tree
#include<stdio.h>
#include<math.h>
int tree[200005],tree2[200005],c[50005];
int MAX(int a,int b){return a>b?a:b;}
int MIN(int a,int b){return a<b?a:b;}
void init(int l,int r,int pos)
{
int mid=(l+r)/2;

if(l==r){ tree[pos]=c[l]; return;}
init(l,mid,2*pos);
init(mid+1,r,2*pos+1);
tree[pos]=MAX(tree[2*pos],tree[2*pos+1]);
}
void init2(int l,int r,int pos)
{
int mid=(l+r)/2;

if(l==r){ tree2[pos]=c[l]; return;}
init2(l,mid,2*pos);
init2(mid+1,r,2*pos+1);
tree2[pos]=MIN(tree2[2*pos],tree2[2*pos+1]);
}
int ques(int l,int r,int pos,int templ,int tempr)
{
int mid=(l+r)/2;

if(templ<=l&&r<=tempr) return tree[pos];
if(templ>mid) return ques(mid+1,r,2*pos+1,templ,tempr);
else if(tempr<=mid) return ques(l,mid,2*pos,templ,tempr);
else return MAX(ques(mid+1,r,2*pos+1,mid+1,tempr),ques(l,mid,2*pos,templ,mid));
}
int ques2(int l,int r,int pos,int templ,int tempr)
{
int mid=(l+r)/2;

if(templ<=l&&r<=tempr) return tree2[pos];
if(templ>mid) return ques2(mid+1,r,2*pos+1,templ,tempr);
else if(tempr<=mid) return ques2(l,mid,2*pos,templ,tempr);
else return MIN(ques2(mid+1,r,2*pos+1,mid+1,tempr),ques2(l,mid,2*pos,templ,mid));
}
int main()
{
int n,q,i,x,y;

while(scanf("%d%d",&n,&q)>0)
{
for(i=1;i<=n;i++) scanf("%d",c+i);
init(1,n,1);
init2(1,n,1);
for(i=0;i<q;i++)
{
scanf("%d%d",&x,&y);
printf("%d\n",ques(1,n,1,x,y)-ques2(1,n,1,x,y));
}
}

return 0;
}

//rmq
#include<stdio.h>
#include<math.h>
int dp[50005][38],dp2[50005][38],c[50005];
int MAX(int a,int b){return a>b?a:b;}
int MIN(int a,int b){return a<b?a:b;}
int main()
{
int n,q,i,j,x,y,k;

while(scanf("%d%d",&n,&q)>0)
{
for(i=0;i<n;i++)
{
scanf("%d",c+i);
dp[i][0]=dp2[i][0]=c[i];
}

for(i=1;(1<<i)<=n;i++)
for(j=0;j+(1<<i)-1<n;j++)
dp[j][i]=MAX(dp[j][i-1],dp[j+(1<<(i-1))][i-1]);

for(i=1;(1<<i)<n;i++)
for(j=0;j+(1<<i)-1<n;j++)
dp2[j][i]=MIN(dp2[j][i-1],dp2[j+(1<<(i-1))][i-1]);

for(i=0;i<q;i++)
{
scanf("%d%d",&x,&y);
x--,y--;
k=(int)(log((y-x+1)*1.0)/log(2.0));
printf("%d\n",MAX(dp[x][k],dp[y-(1<<k)+1][k])-MIN(dp2[x][k],dp2[y-(1<<k)+1][k]));
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: