您的位置:首页 > 产品设计 > UI/UE

uva11039 - Building designing

2013-07-13 17:23 302 查看
Building designing
An architect wants to design a very high building. The building will consist of some floors, and each floor has a certain size. The size of a floor must be greater than the size of the floor immediately above it. In addition, the designer (who is a fan of a famous Spanish football team) wants to paint the building in blue and red, each floor a colour, and in such a way that the colours of two consecutive floors are different.

To design the building the architect has n available floors, with their associated sizes and colours. All the available floors are of different sizes. The architect wants to design the highest possible building with these restrictions, using the available floors.

Input

The input file consists of a first line with the number p of cases to solve. The first line of each case contains the number of available floors. Then, the size and colour of each floor appear in one line. Each floor is represented with an integer between -999999 and 999999. There is no floor with size 0. Negative numbers represent red floors and positive numbers blue floors. The size of the floor is the absolute value of the number. There are not two floors with the same size. The maximum number of floors for a problem is 500000.

Output

For each case the output will consist of a line with the number of floors of the highest building with the mentioned conditions.

Sample Input

2
5
7
-2
6
9
-3
8
11
-9
2
5
18
17
-15
4

Sample Output

2
5

题目大意:给你n个绝对值不相等的数,要求你选择数字排成序列,使得正负交替且绝对值递增。输出最长的序列长度。
分析:水题,按绝对值排序后,正负交替输出即可。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxlen 500010
using namespace std;
int num[maxlen];
bool cmp(int a,int b)
{
return abs(a)<abs(b);
}
int main ()
{
int n,t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=0;i<n;++i)
scanf("%d",&num[i]);
sort(num,num+n,cmp);
int ans=1;
int flag=num[0]>0;
for(int i=1;i<n;++i)
{
if(num[i]<0&&flag)
{
ans++;
flag=0;
}
else if(num[i]>0&&!flag)
{
ans++;
flag=1;
}
}
printf("%d\n",ans);
}

}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: