您的位置:首页 > 其它

hdu1067 N - Gap

2013-07-13 13:09 316 查看
HomeProblemsStatusContest[ak1]Logout
277:06:36
307:00:00



Overview

Problem

Status

Rank

A B C D E F G H I J K L M N O

N - Gap
Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Let's play a card game called Gap. 

You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card. 

First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout. 



Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: "11" to the top row, "21" to the next, and so on. 

Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout. 



At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of "42" is "43", and "27" has no successor. 

In the above layout, you can move "43" to the gap at the right of "42", or "36" to the gap at the right of "35". If you move "43", a new gap is generated to the right of "16". You cannot move any card to the right of a card of value 7, nor to the right of a
gap. 

The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows. 



Your task is to find the minimum number of moves to reach the goal layout.

Input

The input starts with a line containing the number of initial layouts that follow. 

Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards. 

Output

For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout,
produce "-1".

Sample Input

4

12 13 14 15 16 17 21
22 23 24 25 26 27 31
32 33 34 35 36 37 41
42 43 44 45 46 47 11

26 31 13 44 21 24 42
17 45 23 25 41 36 11
46 34 14 12 37 32 47
16 43 27 35 22 33 15

17 12 16 13 15 14 11
27 22 26 23 25 24 21
37 32 36 33 35 34 31
47 42 46 43 45 44 41

27 14 22 35 32 46 33
13 17 36 24 44 21 15
43 16 45 47 23 11 26
25 37 41 34 42 12 31


Sample Output

0
33
60
-1

很水的一个bfs ,基本上,什么都没剪枝就过了,但要注意判重,因为位数太多,可以用hash表,这个小技巧就可以了!

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define maxprime 1000007
struct gaptree{
int map[4][8];
int x[4],y[4],step;
__int64 getall()//得到所有的值 
{
__int64 sum=0;
for(int i=0;i<4;i++)
{
for(int j=0;j<8;j++)
{
sum=(sum<<1)+map[i][j];
}
}
return sum;
}
bool operator == (gaptree aim )const//重载相等
{
for(int i=0;i<4;i++)
for(int j=0;j<=7;j++)
{
if(map[i][j]!=aim.map[i][j])
return false;
}
return true;
}

};

__int64 hash[maxprime];
gaptree start ,end;
__int64 startval,endval;int minstep;
#define inf 0x4f4f4f4f
void init()
{
int temp,ten,i,j;
memset(hash,-1,sizeof(hash));//初始化为没有访问
for(i=0;i<4;i++)
start.map[i][0]=(i+1)*10+1;
for(i=0;i<4;i++)
for(j=1;j<=7;j++)
{
scanf("%d",&temp);
if((temp==11)||(temp==21)||(temp==31)||(temp==41))//移走4个初始值 
{
ten=(temp/10)%10-1;
start.x[ten]=i;
start.y[ten]=j;
start.map[i][j]=0;
}
else{
start.map[i][j]=temp;
}
}
start.step=0;
for(i=0;i<4;i++)
{
for(j=0;j<=6;j++)
{
end.map[i][j]=(i+1)*10+j+1;
}
end.map[i][j]=0;

}
startval=start.getall();
endval=end.getall();
// printf("%I64d %I64d",startval ,endval);
}
bool hashjudge(__int64 val)//hash判重
{
val=val%maxprime;
while(hash[val]!=-1&&hash[val]!=val)//如果没有访问过或访问过,但是由不同的值对应一个hash值,就要扩展表
{
val+=20;
val=val%maxprime;//可能越界 
}
if(hash[val]==-1)//是由于没有访问的
{
hash[val]=val ;
return true;
}
return false ;//是重复访问返回假
}
int bfs()//这也就是最普通的bfs了
{
queue<gaptree > q;
int i,tempnum,tempx,tempy,j,k;
bool flag;
while(!q.empty())
q.pop();
gaptree p,temp;
p=start;
if(startval==endval)
{

return 0;
}
hashjudge(startval);
q.push(start);
while(!q.empty())
{
temp=q.front();
q.pop();
if(temp.getall()==endval)
{
return temp.step;
}
for(i=0;i<4;i++)
{
p=temp;
tempnum=p.map[p.x[i]][p.y[i]-1];//找到要换的空位的左值
if((tempnum%10)==7)//如果左值是7,去掉
continue;
flag=true;
tempnum++;//变成目标值
for(j=0;j<4&&flag;j++)
for(k=1;k<=7&&flag;k++)//找到目标值的坐标
{
if(p.map[j][k]==tempnum)
{

tempx=j;
tempy=k;
flag=false;
}
}
if(!flag)//找到了
{
p.map[tempx][tempy]=0;
p.map[p.x[i]][p.y[i]]=tempnum;
p.x[i]=tempx;p.y[i]=tempy;
p.step=temp.step+1;
if(hashjudge(p.getall()))
{
q.push(p);
}
}

}

}

return -1;
}
int main()
{
int tcase;

scanf("%d",&tcase);
while(tcase--)
{
init();
minstep=bfs();
printf("%d\n",minstep);
}

return 0;
}


FAQ | About Virtual Judge | Forum | Discuss | Open
Source Project

All Copyright Reserved ©2010-2012 HUST ACM/ICPC TEAM 

Anything about the OJ, please ask in the forum, or contact author:Isun

Server Time: 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu1067 N - Gap