您的位置:首页 > 其它

HDU_1016——素环问题DFS

2013-07-12 09:31 274 查看
[align=left]Problem Description[/align]
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.



[align=left]Input[/align]
n (0 < n < 20).

[align=left]Output[/align]
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

[align=left]Sample Input[/align]

6
8

[align=left]Sample Output[/align]

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include <stdio.h>
#include <math.h>
#define MAX 20
int a[MAX],b[MAX],N;
int Is_Prime(int num)
{
for(int i=2;i<=(int)sqrt((double)num);i++)
if(num%i==0)
return 0;
return 1;
}
void Dfs(int n)
{
int i,j;
if(n==N && Is_Prime(a[n-1]+a[0]))
{
for(i=0;i<N;i++)
printf(i==N-1?"%d":"%d ",a[i]);//草蛋的格式
printf("\n");
}
else
{
for(i=1;i<N;i++)
{
if(b[i]!=0 && Is_Prime(a[n-1]+b[i]))
{
a[n++]=b[i];
b[i]=0;
Dfs(n);
b[i]=i+1;
n--;
}
}
}
}
int main()
{
int i,j,k,num=1;
while(scanf("%d",&N)!=EOF)
{
a[0]=1;
for(i=0;i<N;i++)
b[i]=i+1;
printf("Case %d:\n",num++);
Dfs(1);
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: