您的位置:首页 > 其它

ZOJ Problem Set - 1709 Oil Deposits

2013-07-11 23:51 281 查看
ZOJ Problem Set - 1709

Oil Deposits

Time Limit: 2 Seconds
Memory Limit: 65536 KB

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then
analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100.
Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.



Sample Input


1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output

0

1

2

2

简单的深搜题,一遍就过了

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int count;
int m,n;
char map[110][110];
int flag[110][110];
void dfs(int r,int c,int count)
{
if(r<0||c<0||r>=m||c>=n)
return;
else if(flag[r][c]!=0)return;
else if(map[r][c]=='*')return;
else
{
flag[r][c]=count;
dfs(r,c-1,count);
dfs(r-1,c-1,count);
dfs(r-1,c,count);
dfs(r-1,c+1,count);
dfs(r,c+1,count);
dfs(r+1,c+1,count);
dfs(r+1,c,count);
dfs(r+1,c-1,count);
}
}
int main()
{
while((cin>>m>>n)&&m!=0)
{
memset(map,0,sizeof(map));
memset(flag,0,sizeof(flag));
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
cin>>map[i][j];
}
}
count=0;
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
if(flag[i][j]!=0)continue;
if(map[i][j]=='*')continue;
dfs(i,j,++count);
}
}
/*cout<<"=====flag====="<<endl;
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
cout<<flag[i][j]<<' ';
}
cout<<endl;
}
cout<<"=====flag====="<<endl;*/
cout<<count<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: