您的位置:首页 > 其它

杭电1754I Hate It-线段树详细解释和不用线段树解法

2013-07-11 22:13 441 查看

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 25309    Accepted Submission(s): 10028


[align=left]Problem Description[/align]
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。

这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

[align=left]Input[/align]
本题目包含多组测试,请处理到文件结束。

在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。

学生ID编号分别从1编到N。

第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。

接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。

当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。

当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

 

[align=left]Output[/align]
对于每一次询问操作,在一行里面输出最高成绩。
 

[align=left]Sample Input[/align]

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

 

[align=left]Sample Output[/align]

5
6
5
9

HintHuge input,the C function scanf() will work better than cin//----------------------------------------------------------------------------*/
有两种方法,第一种是线段树,第二种是模拟
下面是线段树的详细解释和代码,不会线段树的或者不太熟的建议多看看第一种,看完就看第二种,我自己写的,第一种是网上COPY别人的,其实理解了线段树算法,第一种方法是很容易想到和敲出来的,当然线段树是很好的方法,至少我认为比第二种模拟方法要好,因为如果测试数据太大的话第二种方法就不行了-肯定会超时的。所以我网上COPY来的代码是为了读者更好的掌握线段树方法,而第二种方法看看就好....第一种:(线段树法)
#include <stdio.h>
#include <conio.h>
#include <string.h>

#define max(x1, y1) ((x1) > (y1) ? (x1) : (y1))
#define min(x1, y1) ((x1) < (y1) ? (x1) : (y1))

#define MAXSIZE 200002

typedef struct {
int max ;
int left, right ;
} NODE ;

int n, m ;
int num [MAXSIZE] ;
NODE tree[MAXSIZE * 20] ;

// 构建线段树
int build (int root, int left, int right)
{
int mid ;

// 当前节点所表示的区间
tree[root].left = left ;
tree[root].right = right ;

// 左右区间相同,则此节点为叶子,max 应储存对应某个学生的值
if (left == right)
{
return tree[root].max = num[left] ;
}
mid = (left + right) / 2 ;

// 递归建立左右子树,并从子树中获得最大值
int a, b ;
a = build (2 * root, left, mid) ;
b = build (2 * root + 1, mid + 1, right) ;

return tree[root].max = max (a, b) ;
}

// 从节点 root 开始,查找 left 和 right 之间的最大值
int find (int root, int left, int right)
{
int mid ;
// 若此区间与 root 所管理的区间无交集
if (tree[root].left > right || tree[root].right < left)
return 0 ;
// 若此区间包含 root 所管理的区间
if (left <= tree[root].left && tree[root].right <= right)
return tree[root].max ;

// 若此区间与 root 所管理的区间部分相交

int a, b ; // 不能这样 max (find(...), find(...));
a = find (2 * root, left, right) ;
b = find (2 * root + 1, left, right) ;

return max (a, b) ;
}

// 更新 pos 点的值
int update (int root, int pos, int val)
{
// 若 pos 不存在于 root 所管理的区间内
if (pos < tree[root].left || tree[root].right < pos)
return tree[root].max ;

// 若 root 正好是一个符合条件的叶子
if (tree[root].left == pos && tree[root].right == pos)
return tree[root].max = val ;

// 否则。。。。

int a, b ; // 不能这样 max (find(...), find(...));
a = update (2 * root, pos, val) ;
b = update (2 * root + 1, pos, val) ;

tree[root].max = max (a, b) ;

return tree[root].max ;
}

int main ()
{
char c ;
int i ;
int x, y ;
while (scanf ("%d%d", &n, &m) != EOF)
{
for (i = 1 ; i <= n ; ++i)
scanf ("%d", &num[i]) ;
build (1, 1, n) ;

for (i = 1 ; i <= m ; ++i)
{
getchar () ;
scanf ("%c%d%d", &c, &x, &y) ;
if (c == 'Q')
{
printf ("%d\n", find (1, x, y)) ;
}
else
{
num[x] = y ;
update (1, x, y) ;
}
}
}
return 0 ;
}
第二种方法:(模拟法)#include<iostream>
#include<cstdio>
#include<cstring>
const int MAX=200005;
int s[MAX];
int maxn;
int t;
using namespace std;
void Q_Query()
{
int a,b;
scanf("%d%d",&a,&b);
if(t>=a&&t<=b)
{
printf("%d\n",maxn);
return;
}
int Maxn=-1;
for(int i=a;i<=b;i++)
{
if(s[i]>Maxn)
{
Maxn=s[i];
}
}
printf("%d\n",Maxn);
}
void U_Query()
{
int a,b;
scanf("%d%d",&a,&b);
s[a]=b;
if(b>maxn)
{
maxn=b;
t=a;
}
}
int main()
{
int n,m,i;
char a;
while(scanf("%d%d",&n,&m)!=EOF)
{
maxn=-1;
for(i=1;i<=n;i++)
{
scanf("%d",&s[i]);
if(s[i]>maxn)
{
maxn=s[i];
t=i;
}
}
for(i=0;i<m;i++)
{
cin>>a;
if(a=='Q')
{
Q_Query();
}
else if(a=='U')
{
U_Query();
}
}
}
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息