您的位置:首页 > 其它

ZOJ Problem Set - 1171 Sorting the Photos

2013-07-09 16:36 288 查看
ZOJ Problem Set - 1171

Sorting the Photos

Time Limit: 2 Seconds
Memory Limit: 65536 KB

Imagine you have a pile of 1 <= N <= 10^5 photos. Some of them are faced upwards and the others faced downwards. Your goal is to sort them so all the photos are faced the same direction. The only operation you are allowed to do is to take any amount
of the photos from the top into the separate pile, turn that pile upside-down as the whole and put it back over the rest of original pile.

Write the program that calculates the minimum number of such operations needed to complete the sorting goal.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

First line of the input contains the only number. Then, characters going possibly separated by newline and/or space characters "D" - faced down or "U" - faced up.

Output

Single integer number - minimal number of flip operations required to sort the photos pile.

Sample Input

1

5

UU D

UU

Sample Output

2

AC代码:

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
int cas;
cin>>cas;
while(cas--)
{
int n;
cin>>n;
char *pt=new char
;
for(int i=0;i<n;i++)cin>>pt[i];
char tag=pt[0];
int count=0;
for(int i=1;i<n;i++)
{
if(tag!=pt[i])
{
tag=pt[i];
count++;
}
}
cout<<count<<endl;
if(cas!=0)cout<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: